Application Perf Mgmt (BAC / BSM) Support and News Forum
Showing results for 
Search instead for 
Do you mean 

How to disable session data flowing from Probes to Engines

SOLVED
Go to Solution
Occasional Advisor

How to disable session data flowing from Probes to Engines

[ Edited ]

Hello everyone.

 


When we look at System Health on RUM Engine's WebConsole we see error on "Real User Monitor Sniffer Probe Host -> Active Sessions" which says greater than 50k. Is there a configuration on probes or engines to totaly discard these session data, because our application doesn't use session machanism at all.

 

error.png 

 

Thanks all.

1 ACCEPTED SOLUTIONS
HPE Expert

Re: How to disable session data flowing from Probes to Engines

Hi.

 

There is no way to disable this without having a negative impact on the probe. You can increase the number for not seeing it as an error (HPRUM\conf\monitoringmanager\Probe\ProbeActiveSessionsMonitor.xml) but you might get at the end to an OOM in the probe, and make it crash.

Without a good session detection in place (In the RUM web console, Use Probe Management > Session ID Detection) you will have multiple user sessions combined together and not closed on the right time which will cause a high number of active sessions.

you might also try to use the session close URL.

mainly you need to see how to have your sessions closed on time and not hanging open, or you also might have too much traffic (over the probe limit).

If this information is not enough, please open a support case.

 

Amichai

 

2 REPLIES
HPE Expert

Re: How to disable session data flowing from Probes to Engines

Hi.

 

There is no way to disable this without having a negative impact on the probe. You can increase the number for not seeing it as an error (HPRUM\conf\monitoringmanager\Probe\ProbeActiveSessionsMonitor.xml) but you might get at the end to an OOM in the probe, and make it crash.

Without a good session detection in place (In the RUM web console, Use Probe Management > Session ID Detection) you will have multiple user sessions combined together and not closed on the right time which will cause a high number of active sessions.

you might also try to use the session close URL.

mainly you need to see how to have your sessions closed on time and not hanging open, or you also might have too much traffic (over the probe limit).

If this information is not enough, please open a support case.

 

Amichai

 

Highlighted
Occasional Advisor

Re: How to disable session data flowing from Probes to Engines

Thank you for your help...