Application Perf Mgmt (BAC / BSM) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

How to remove "Moving Averages" from Custom Reports

SOLVED
Go to Solution
Occasional Advisor

How to remove "Moving Averages" from Custom Reports

Hi all,

 

I am having issues removing the "Moving Averages" from a "Metrics Over Time" custom report.

 

Checking on the documentation it says it should be disabled by default an in order to activate it you need to navigate to the Infrastructure settings so I have navigated to:

 

1. Select Admin > Platform > Setup and Maintenance > Infrastructure Settings.

2. Select Foundations.

3. Select Reporting.

4. In the Reporting - Display table, locate Global reports display customization. Change the

value to the XML script for the report components you want to customize.

 

as well as the Specific reports display customization. option on the same path.

 

However the settings there are an a XML and all the content is commented so no idea what setting I need to change in order to remove the MA graphs from my Custom Reports.

 

I'll appreciate any help with this issue.

3 REPLIES
Trusted Contributor

Re: How to remove "Moving Averages" from Custom Reports

Hi, you can't change ti VIA UI: 

 

Open : HPBSM\conf\settings\diagnostics.xml

search for "com.mercury.am.bac.eum.reports.common.data.generation.metrics.over.time.display.avg".

Edit: displayInUI="false"

Restart GW machine 

 

Note: this setting is hidden in the UI (at least for the moment).

Regards,
Noam

Highlighted
Occasional Advisor

Re: How to remove "Moving Averages" from Custom Reports

Thanks for the information!!

Advisor

Re: How to remove "Moving Averages" from Custom Reports

Hi,

 

Even after making the changes in Diagnostic xml file as per your suggestion, moving average is still being displayed in the Metric Over Time report. I have restared the services too. Any other workaround you can suggest for this?