Application Perf Mgmt (BAC / BSM) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

OMi Console missing in BSM

SOLVED
Go to Solution
Advisor

OMi Console missing in BSM

Hi Team,

 

We have BSM9.13 on Windows (2G/W and DPS in high availability). Each time when we restart BSM, the OMi applictaion console is missing in BSM.

 

Has anyone encountered this issue.? Kinldy suggest. Below are the error we get in startup log...

 

2013-06-13 03:21:37,178 - 2013-06-13 03:21:37,175 [main] (TomcatDeployer.java:127) INFO  - deploy, ctxPath=/opr-console, warUrl=file:/E:/HPBSM/AppServer/webapps/opr-console.war/
2013-06-13 03:29:10,199 - 2013-06-13 03:29:10,194 [main] (MainDeployer.java:1036) ERROR - Could not start deployment: file:/E:/HPBSM/AppServer/webapps/opr-console.war/
2013-06-13 03:29:10,199 - org.jboss.deployment.DeploymentException: URL file:/E:/HPBSM/AppServer/webapps/opr-console.war/ deployment failed
2013-06-13 03:29:10,200 -        at org.jboss.web.tomcat.service.TomcatDeployer.performDeployInternal(TomcatDeployer.java:386)
2013-06-13 03:29:10,200 -        at org.jboss.web.tomcat.service.TomcatDeployer.performDeploy(TomcatDeployer.java:104)
2013-06-13 03:29:10,200 -        at org.jboss.web.AbstractWebDeployer.start(AbstractWebDeployer.java:375)
2013-06-13 03:29:10,200 -        at org.jboss.web.WebModule.startModule(WebModule.java:83)
2013-06-13 03:29:10,200 -        at org.jboss.web.WebModule.startService(WebModule.java:61)
2013-06-13 03:29:10,200 -        at org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanSupport.java:289)
2013-06-13 03:29:10,200 -        at org.jboss.system.ServiceMBeanSupport.jbossInternalLifecycle(ServiceMBeanSupport.java:245)
2013-06-13 03:29:10,200 -        at sun.reflect.GeneratedMethodAccessor7.invoke(Unknown Source)
2013-06-13 03:29:10,200 -        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
2013-06-13 03:29:10,200 -        at java.lang.reflect.Method.invoke(Method.java:597)
2013-06-13 03:29:10,201 -        at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
2013-06-13 03:29:10,201 -        at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
2013-06-13 03:29:10,201 -        at org.jboss.mx.server.Invocation.invoke(Invocation.java:86)
2013-06-13 03:29:10,201 -        at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
2013-06-13 03:29:10,201 -        at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
2013-06-13 03:29:10,201 -        at org.jboss.system.server.jmx.LazyMBeanServer.invoke(LazyMBeanServer.java:291)
2013-06-13 03:29:10,201 -        at org.jboss.system.ServiceController$ServiceProxy.invoke(ServiceController.java:978)
2013-06-13 03:29:10,201 -        at $Proxy0.start(Unknown Source)
2013-06-13 03:29:10,201 -        at org.jboss.system.ServiceController.start(ServiceController.java:417)
2013-06-13 03:29:10,201 -        at sun.reflect.GeneratedMethodAccessor14.invoke(Unknown Source)
2013-06-13 03:29:10,201 -        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
2013-06-13 03:29:10,202 -        at java.lang.reflect.Method.invoke(Method.java:597)
2013-06-13 03:29:10,202 -        at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
2013-06-13 03:29:10,202 -        at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
2013-06-13 03:29:10,202 -        at org.jboss.mx.server.Invocation.invoke(Invocation.java:86)
2013-06-13 03:29:10,202 -        at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
2013-06-13 03:29:10,202 -        at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
2013-06-13 03:29:10,202 -        at org.jboss.system.server.jmx.LazyMBeanServer.invoke(LazyMBeanServer.java:291)
 
________________________________________

11 REPLIES
Honored Contributor

Re: OMi Console missing in BSM

Can you upload the screenshot for me so that I get to see what you are seeing?

 

--Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Advisor

Re: OMi Console missing in BSM

Hi Sujith,

 

Previously we were getting 404 Page not found error. Now after the BSM restart, event consle tries to load, but never get loaded..

 

Thanks .!

Highlighted
Honored Contributor

Re: OMi Console missing in BSM

Was this working before? I assume you are accessing BSM through Load balancer. Can you try accessing BSM directly through one of the gateway server? Also can you close all the events and purge them and let us know the result.

 

Use Java 1.6 Update XX. Java 1.7 is not supported yet on BSM 9.13

 

Regards,

Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Advisor

Re: OMi Console missing in BSM

Yes, It was working before. But we noticed that most of the times when we restart BSM, the opr-console deployment get failed and some files (opr-console.war) will be missing in the server and we get 404 page not found error.

 

But in this case , the event console  tries to load and does'nt get loaded as in the screen shot.

 

Also yes, we have loadbalancing, But the error screenshot I attached was what we get from individual gateways. it is not loading from both gateways either

 

Also we noticed that when we run dbverify utility from gateway, we get the attached error.

 

Thanks.!

 

Regards,

Shalini

Advisor

Re: OMi Console missing in BSM

Also we tried closing and archiving the OMi events, but didnt help..

Honored Contributor

Re: OMi Console missing in BSM

What does this mean?

 

"But we noticed that most of the times when we restart BSM, the opr-console deployment get failed and some files (opr-console.war) will be missing in the server"

 

Screenshot please?

 

--Sujith

Close the thread if your issue is resolved to make the thread meaningful and complete. Do show gratitude to people who helped you by assigning points.
Advisor

Re: OMi Console missing in BSM

Currently we dont have this issue. All the files are in place. But in past we noticed that the opr-console.war folder under the Appserver\webapps folder was missing on 1 or both gateways after the restart of BSM. and in that case we used to get page not found error.

 

Currently we have all the files in place and as per the sugeestion i previous post , we tried closing all OMI events and archiving it, but that didnt help. The page still shows in loading state and never get loaded.

 

Also I had attached the dbverify error message in previous post. Could you please look in to that issue.

 

Thanks !

 

Regards

Shalini

Trusted Contributor

Re: OMi Console missing in BSM

Hi,

I have faced the same issue but for SAM and not OMi,we updated the license and it works fine.Previous to this we are using EVAL license.

Are you using Eval license ?

Regards,
hp4u
Advisor

Re: OMi Console missing in BSM

The issue is solved with the help of HP Support. The issues were Huge number of events in db and g/w cache corruption.

 

Thanks for everyones support.!

 

Trusted Contributor

Re: OMi Console missing in BSM

Can you share the high level steps?

Regards,
hp4u
Honored Contributor Honored Contributor

Re: OMi Console missing in BSM

any idea

 

we are also facing same issue

Cheers!

Nvr Blame a day in ur life....... Good day gives "happiness" & Bad day gives "experience" ......