Application Perf Mgmt (BAC / BSM) Support and News Forum
Showing results for 
Search instead for 
Do you mean 

Reset HI not working in BSM 9.22 Service Health

Frequent Advisor

Reset HI not working in BSM 9.22 Service Health



We have a BSM 9.22 system (OMi) that is receiving events from BSM Connectors that are using ETIs to set HI state. This is all working fine with set events changing the HI state to major, critical or whatever, and clear events setting the HI state back to normal.


In a few cases we have had 2 events arrive at the same time, one set and one clear. The result is that the HI is changing state to critical but not then straight back to normal. In these cases I've tried drilling down to the CI in the Service Health Hierarchy view, clicking on the little down arrow next to the CI name, clicking on Show HIs, then for the HI clicking on Reset Health Indicator. When I do this it gives me a message saying the reset was sucessful and the status will be updated on the next refresh - but it never does.


For cases like this where we have the events in the closed events browser, I reopen the event then once open I select Close and Reset Health Indicator - this does work.


The problem is for some instances the event is no longer in the closed events browser, leaving me no way to reset the HI unless I inject a new normal event.


Is there another way to reset a HI that does actually work?


Esteemed Contributor Esteemed Contributor

Re: Reset HI not working in BSM 9.22 Service Health

hello sean

i have noticed the very same thing but not for HIs based on events but for HIs based on sample from SiteScope. Using the "Reset HI" functionality from the Service Health UI will not really impact the HI status.

i was not certain if there is a problem with our implementation here. but since you're reporting the same thing i am starting to see a bug as a possible reason for this.

sorry not a big help. maybe someone else has additional info.

btw. this is for bsm 9.23 in my case