Application Perf Mgmt (BAC / BSM) Support and News Forum
Showing results for 
Search instead for 
Do you mean 

SSH Connectivity Issues on Sitescope 11.01

Regular Advisor

SSH Connectivity Issues on Sitescope 11.01

[ Edited ]


   Pardon me if this has been asked before, but my searches have come up empty. We are running Sitescope 11.01, and have multiple Sitescope servers, all running as VMs on a VMWare farm. On one particular Sitescope server, on occasion, we'd get SSH Timeout errors. It would cause "no data" false positives and also fill up the Monitors Running/Waiting.


It's acting like a connection got stuck, as I'm seeing errors such as:

Got to the limit of SSH connections: 7 for remote: <ip>, waited: 60034 milliseconds for the next available connection.Consider increasing the max number of SSH connections allowed for this remote.


Sometimes, it clears up, and sometimes it doesn't, but it always causes concern and discussion internally. We have reduced the number of SSH connections over time, and I even removed any Unix/Linux Profile connections that didn't have any monitors associated to them. We also make extensive use of SSH V2, so I also try to keep them forced to V2 when possible. I did clean up a few of those after yesterday's incident.


My SSH Preference Settings are:

SSH V2 connection timeout: 30

SSH V2 hello timeout: 30

SSH v2 key exchange timeout: 30

SSH V2 authentication phase timeout: 60


Monitor Count info:

Total monitors: 2902
Total URLSequence Steps: 0
Total URLList Items: 0
Total Points Used: 2926
Total Hosts : 458


The Hosts are a mixture of Windows and Linux (mostly Red Hat)


My research did point to a patch for 10.x. Has anyone else seen any such issues with 11.x?