Application Perf Mgmt (BAC / BSM) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

SiteScope Frontend applet not loading - Class Not found exception

SOLVED
Go to Solution
Highlighted
Occasional Advisor

SiteScope Frontend applet not loading - Class Not found exception

All,

 

i was trying to access the sitescope's frontend GUI url and it seems like the applets fails to load and when i look at the java console, it shows the below error.  i thought it was a client issue and tried to update my java and tried several troubleshooting, but nothing helped.

 

Btw, i verified this particular jar file exists under /opt/HP/SiteScope/jsp/applets/SiteScope/lib.

 

java.lang.ClassNotFoundException: com.mercury.sitescope.ui.SiteScopeConfigurationApplet
 at java.net.URLClassLoader$1.run(Unknown Source)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.net.URLClassLoader.findClass(Unknown Source)
 at java.lang.ClassLoader.loadClass(Unknown Source)
 at java.lang.ClassLoader.loadClass(Unknown Source)
 at java.lang.Class.forName0(Native Method)
 at java.lang.Class.forName(Unknown Source)
 at com.hp.acm.swing.container.bootstrap.AppletBootstrap.createImplementation(AppletBootstrap.java:386)
 at com.hp.acm.swing.container.bootstrap.AppletBootstrap.access$900(AppletBootstrap.java:47)
 at com.hp.acm.swing.container.bootstrap.AppletBootstrap$BgInitThread$1.run(AppletBootstrap.java:678)
 at java.security.AccessController.doPrivileged(Native Method)
 at com.hp.acm.swing.container.bootstrap.AppletBootstrap$BgInitThread.run(AppletBootstrap.java:515)
java.lang.ClassNotFoundException: com.mercury.sitescope.ui.SiteScopeConfigurationApplet
 at java.net.URLClassLoader$1.run(Unknown Source)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.net.URLClassLoader.findClass(Unknown Source)
 at java.lang.ClassLoader.loadClass(Unknown Source)
 at java.lang.ClassLoader.loadClass(Unknown Source)
 at java.lang.Class.forName0(Native Method)
 at java.lang.Class.forName(Unknown Source)
 at com.hp.acm.swing.container.bootstrap.AppletBootstrap.createImplementation(AppletBootstrap.java:386)
 at com.hp.acm.swing.container.bootstrap.AppletBootstrap.access$900(AppletBootstrap.java:47)
 at com.hp.acm.swing.container.bootstrap.AppletBootstrap$BgInitThread$1.run(AppletBootstrap.java:678)
 at java.security.AccessController.doPrivileged(Native Method)
 at com.hp.acm.swing.container.bootstrap.AppletBootstrap$BgInitThread.run(AppletBootstrap.java:515)
[Applet Bootstrap ERROR] com.mercury.sitescope.ui.SiteScopeConfigurationApplet

 

Any help/suggestions would be greatly appreciated.  Thanks in advance.

 

3 REPLIES
Respected Contributor

Re: SiteScope Frontend applet not loading - Class Not found exception

Think I had similar problems. Do you use a proxy server by any chance?

 

Do you get an error message if you try loading the Sitescope GUI directly from the Sitescope machine itself? If it's a Windows machine, RDP to it, launch the browser and try going to http://localhost:8080. If you get an error there, it's most likely a problem with Sitescope itself, but if it loads fine, then it's most likely on the client side.

 

What worked for me was to change my Java connection settings (Control Panel > Java > Network Settings), changing it to "Direct Connection", deleting all temporary Java files, clearing my browser cache and reloading.

Honored Contributor Honored Contributor

Re: SiteScope Frontend applet not loading - Class Not found exception

Clear Browser & java cache.

Also i would suggest have reboot to server once and revert if u still face the issue
Cheers!

Nvr Blame a day in ur life....... Good day gives "happiness" & Bad day gives "experience" ......
Occasional Advisor

Re: SiteScope Frontend applet not loading - Class Not found exception

Yes, that was one of the problem,  however when i tried to uninstall the patch 11.12 and revert it to 11.10 or upgrade it to 11.13 it worked, any reason?