Application Perf Mgmt (BAC / BSM) Support and News Forum
Showing results for 
Search instead for 
Do you mean 

Sitescope 9.5 NT Performance Counters

Occasional Contributor

Sitescope 9.5 NT Performance Counters

Hi

We renamed a production server and the majority of the existing counters worked - the exception is the performance counters for specific MSMQ queues.

Selecting the MSMQ counter object name results in the message *** Counter object not found in the system*** after pressing the 'List Objects and Enumerate Counters' button.

Other performance counters such as WMI objects work fine.
The counters work within perfmon (Win2k3).
I have used LODCTR to reload mqperf.ini

Any thoughts as to how to progress?
4 REPLIES
Respected Contributor Respected Contributor

Re: Sitescope 9.5 NT Performance Counters (problem still in SS 11.22)

Have exactly same problem in SiteScope 11.22

 

The problem is that MSMQ full counter name in monitor will look like this

 

MSMQ Queue\server-name\private$\admin_queue$\Messages in Queue

 

 

Obviously it messes up Sitescope, because counter instance contains '\' chars itself.

 

Can't manage to fix it, tried something like

MSMQ Queue\server-name\\private$\\admin_queue$\Messages in Queue

didn't help

 

Funny - if you specify counter name with regex

/^MSMQ Queue\.*\Messages in Queue$/

SiteScope will find all counters correctly:

 

MSMQ Queue\server-name\private$\admin_queue$\Messages in Queue

MSMQ Queue\server-name\private$\server_queue$\Messages in Queue

...

 

But SiteScope can't get values for counters :(

 

Anybody know how to fix this?

Respected Contributor Respected Contributor

Re: Sitescope 9.5 NT Performance Counters (problem still in SS 11.22)

Have found workaround

 

change remote server connection to NETBIOS, everything start to work :(

HPE Expert

Re: Sitescope 9.5 NT Performance Counters (problem still in SS 11.22)

Porblem may be with WMI.

"The counters work within perfmon (Win2k3)"

You may validate by running perfmon in wmi mode and by SiS service user:

Runas /user DOMAIN\user "perfmon.exe /wmi"
Kenneth Gonzalez
HP Support

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

If you haven’t tried it yet, come and join us in our entitled forums at Support Customer Forums
Highlighted
Respected Contributor Respected Contributor

Re: Sitescope 9.5 NT Performance Counters (problem still in SS 11.22)

Thanks for your suggestion, Kenneth.

 

I think perfmon.exe /wmi doesn't work in current OS'es - Win7/2008.

 

And the problem is that OTHER counters (for example, Processor or Memory) work well via WMI/NETBIOS. But MSMQ counters - only via NETBIOS.