Application Perf Mgmt (BAC / BSM) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Unix server connection issue through sitescope

SOLVED
Go to Solution
Occasional Advisor

Unix server connection issue through sitescope

Hi,

Recently I installed SiteScope Ver 11.10 for monitoring resources utilization of Unix Server. But when I tried to connect through Unix Resources. It was connected once but now getting below issue.

Testing connection to :
Attempting SSH V1 connect.
SSH V1 connect failed
Attempting SSH V2 connect
SSH V2 connect failed

remote command error (-1)

remote command error (-1)

Kindly help me how I can overcome the above issue.
15 REPLIES
Esteemed Contributor Esteemed Contributor

Re: Unix server connection issue through sitescope

Hi,

check the credentials you provided is correct or not in remote unix, do the detail test there.

try to connecto your unix server through putty from the sitescope server and check.

-Krishna Rajapantula.
Occasional Advisor

Re: Unix server connection issue through sitescope

It was connected through putty.exe externally. Can u pls guide me how I can connect unix server through putty from the sitescope server.
Esteemed Contributor Esteemed Contributor

Re: Unix server connection issue through sitescope

Hi, Girish.

There are two possible reasons for this error.

First one is that due to some routing or resolving issues your SiteScope machine can't connect to the remote Unix server.
To check this, please, copy putty to SiteScope machine and try to connect to Unix you want to monitor.

The second possible reason is that it is SiteScope-related issue.
Could you, please, name what Unix you're trying to connect to and attach /etc/ssh/sshd_config from that target Unix and screenshot of this Unix remote server properties in SiteScope?

Thank you.
Sergey.
_______________
This thread is now 20% cooler
Occasional Advisor

Re: Unix server connection issue through sitescope

Hi Sergey,

Thx for reply. There was an issue regarding connection from site scope server I verified the same through putty from server. Now able to connect with the remote server.
Esteemed Contributor Esteemed Contributor

Re: Unix server connection issue through sitescope

It's good to hear it.

Have a good SiteScope experience)!
_______________
This thread is now 20% cooler
Occasional Advisor

Re: Unix server connection issue through sitescope

Hi Sergey,

Can u pls guide me how I can set auto refresh rate for created monitors, currently monitor status gets updated when I manually click on Run Monitor option. Is there any option to do the same so that sitescope do it auto after particular time interval.
Esteemed Contributor Esteemed Contributor

Re: Unix server connection issue through sitescope

Each monitor has "Monitor Run Settings" in its properties.
There you can set:
- frequency - monitor run rate
- error frequency - monitor run rate if it is in error state

Please, look at attached picture for illustration.
_______________
This thread is now 20% cooler
Highlighted
Occasional Advisor

Re: Unix server connection issue through sitescope

thx :-)

Re: Unix server connection issue through sitescope

HI,

 

I have a problem with SSH for AIX, Putty is working from the SIS server and getting connected, any help please

 

BR

Osama Selwadi - SSBS
Occasional Visitor

Re: Unix server connection issue through sitescope

Thanx Sergey..

Member
Occasional Visitor

Re: Unix server connection issue through sitescope

Hi,

I've setup SiteScope for monitoring resources utilization of Datapower Server. But when I tried to connect through Unix Resources. It was giving below issue.

Testing connection to :
Attempting SSH V1 connect.
SSH V1 connect failed
Attempting SSH V2 connect
SSH V2 connect failed

remote command error unknown error (-1) (-1)
I carried out test and detailed test. For both test I'm getting the above message.
Kindly help me how I can overcome the above issue.
Occasional Visitor

Re: Unix server connection issue through sitescope

I am facing similar issue when trying to setup unix monitoring using SSH. Can anyone let me know what are the sitescope settings that we need to do?
Error: remote connect error -1
HPE Expert

Re: Unix server connection issue through sitescope

hello!

 

Which sitescope versions are we talking about?

 

Please upload the ERROR.LOG and RUNMONITOR.LOG so we have a bit more info here.

 

BR-Patrick

Advisor

Re: Unix server connection issue through sitescope

I'm having the same issue.

 

Connecting using Putty from the Sitescope server works fine.

From Sitescope web it does not.

 

Here's the sshd_config of the Debian Linux server I want to monitor:

 

#PasswordAuthentication yes

# Kerberos options

#KerberosAuthentication no

#KerberosGetAFSToken no

#KerberosOrLocalPasswd yes

#KerberosTicketCleanup yes

# GSSAPI options

#GSSAPIAuthentication no

#GSSAPICleanupCredentials yes

X11Forwarding yes

X11DisplayOffset 10

PrintMotd no

PrintLastLog yes

TCPKeepAlive yes

#UseLogin no

#MaxStartups 10:30:60

#Banner /etc/issue.net

# Allow client to pass locale environment variables

AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,

# and session processing. If this is enabled, PAM authentication will

# be allowed through the ChallengeResponseAuthentication and

# PasswordAuthentication.  Depending on your PAM configuration,

# PAM authentication via ChallengeResponseAuthentication may bypass

# the setting of "PermitRootLogin without-password".

# If you just want the PAM account and session checks to run without

# PAM authentication, then enable this but set PasswordAuthentication

# and ChallengeResponseAuthentication to 'no'.

UsePAM yes

 

Attached is a screenshot of the settings in Sitescope.

 

Any ideas how to get this working?

 

Thanks

 

 

Re: Unix server connection issue through sitescope

I removed the Domain name and it works like charm