Application Perf Mgmt (BAC / BSM) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

VuGen 11.5 error when trying to record a new script: Class not registered

Advisor

VuGen 11.5 error when trying to record a new script: Class not registered

Hi,

 

I've installed VuGen 11.5 with Patch 11.51. When trying to record a new script I receive the following error directly after choosing the Web protocol:

 

General:

HP.LR.VuGen.ParametersService

Void RegisterToEvents(HP.Utt.ProjectSystem.IUttScript)

Retrieving the COM class factory for component with CLSID {2CBD64DF-B0FE-443A-A701-6815A16E2CD6} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

 

How do I fix this problem?

 

Thx in advance and regards,

Timo 

4 REPLIES
Occasional Visitor

Re: VuGen 11.5 error when trying to record a new script: Class not registered

Hi

 

May i check if you managed to resolve your issue

I m having exact same issue on windows 7 pc [32-bit]. Thanks

Advisor

Re: VuGen 11.5 error when trying to record a new script: Class not registered

We still have no solution for this error, sorry.

Occasional Advisor

Re: VuGen 11.5 error when trying to record a new script: Class not registered

Steps to solve the issue..



This issue is coming due to registration failure and the log can be found in "C:\Windows\Temp\HP_[ProductName]_RegistrationFailure.log".



The below mentioned steps solved the issue in my machine!!



Step 1: Copy the Registration failure log (C:\Windows\Temp\HP_[ProductName]_RegistrationFailure.log) to Desktop



Step 2: Remove all "ERROR ON COMMAND:" string from the file



Step 3: Then change the path from "C:\Windows\SysWOW64\regsvr32.exe" to "C:\Windows\System32\regsvr32.exe"



Step 4: Save the file with (<filename.bat>) ".bat" extension



Step 5: Double Click the batch file to run



Now open the Vugen.. It will open without any issues!!
Highlighted
Visitor

Re: VuGen 11.5 error when trying to record a new script: Class not registered

Hi 

  

In temp folder there are two log files HP_LoadRunner_11.50_RegistrationFailure and
HP_LoadRunner_Service_Pack_11.52_RegistrationFailure. in which i have to do the changes?

 

well i did the changes u mentioned with the first one and while running the batch file i came across an application error

like below

 

later i tried with second one too. It displayed same error.

 

please suggest

 

Thanks,

ramya