Client Automation Enterprise Admin (Radia) Forum
Showing results for 
Search instead for 
Do you mean 

Error Uninstalling Service Error 833

Frequent Advisor

Error Uninstalling Service Error 833

Hi,
I use Radia 5.x . I installed an app via Software manager and then changed Zsvcmode to OM and ran a Update. when i tried to uninstall the app i got "Error Uninstalling Service: Error[833]".

Can anyone help me in sorting out this?

Regards,
Nathan.
8 REPLIES
Respected Contributor Respected Contributor

Re: Error Uninstalling Service Error 833

Are you able to post the client logs?
Honored Contributor Honored Contributor

Re: Error Uninstalling Service Error 833

does the same thing happen if you left ZSVCMO at O. Maybe this issue is nothing to do with the change you made as it could be that your delete method is calling a file resource that is removed before the method is actually called - as is the norm... In which case you'd need to use the BEDELETE method instead of ZDELETE. Just a thought.

HTH.

Karl.
Frequent Advisor

Re: Error Uninstalling Service Error 833

Hi Karl,
This is the same case when Zscvcmode is O or M too. We have a taskill command in Bdelete. This is a Service group application in which 3 zservices are attached. The uninstallation problem exist with the main application. Other two zservices are getting uninstalled properly.

Regards,
Nathan.
Honored Contributor Honored Contributor

Re: Error Uninstalling Service Error 833

OK so this issue is nothing to do with ZSVCMO setting. Good to know...

So on the main application what is the ZDELETE method set to?
And is the main application the same app\service that has the BDELETE task kill method? You last post wasn't entirely clear how the deletes are coded.

Karl.
Trusted Contributor Trusted Contributor

Re: Error Uninstalling Service Error 833

How is the service packaged - Component Selection/Installation Monitor/MSI import? What is the uninstall method, and does it work successfully if run manually outside of Radia?
Frequent Advisor

Re: Error Uninstalling Service Error 833

Hi,
we have done it through adavanced mode packaging.The MSI works correctly as expected.In the Bdelete we have given task kill for killing a service which will be running when the app is launched even after closing also. In Zdelete it is normal RADMSI /u command.
Trusted Contributor Trusted Contributor

Re: Error Uninstalling Service Error 833

I'd suggest putting the uninstall command into a .CMD file, along with the taskkill, and then call that CMD file from the BDELETE.

I suspect that as has been suggested before, something required for the uninstall to happen is getting removed prior to the actual uninstall command running (hope that makes sense!).
Respected Contributor Respected Contributor

Re: Error Uninstalling Service Error 833

Are you able to post the client logs?

You say you have the application amongst a group of services. What happens when you split these applications from the service group (have them individually) and assign them, then remove them? (does the same things happen?).

Does the application even attempt to uninstall? (do you see any files being removed or the MSI being called? (if its an MSI file))?

if the MSI is being called try checking the MSIInfo.log file during uninstallation.