Client Automation Enterprise Infrastructure (Radia) Forum
Showing results for 
Search instead for 
Do you mean 

Problem deploying an application to a Windows 7 OS with HPCA agent version 5.1 installed

Frequent Advisor

Problem deploying an application to a Windows 7 OS with HPCA agent version 5.1 installed

Hello,

 

I have a Windows 7 OS which has HPCA agent version 5.1 installed.  I am able to deploy most files to the OS but it fails when trying to create a folder in C:\Windows\winsxs\.  The following line is appears in connect.log:

 

Directory exists or could not be creasted: C:\Windows\winsxs\x86_microsoft.vc80.openmp_(letters and numbers)

 

I verified that the folder does not exist, so I looked at permissions and see that only the TrustedInstaller is capable of creating folders.

 

Any suggestions of a work around?  We are in the midst of having an HP consultant come onsite to migrate our system from 5.1 to 7.9 but I have a need for this until we have completed the upgrade.

 

Thanks for your help

 

Kevin

3 REPLIES
Valued Contributor

Re: Problem deploying an application to a Windows 7 OS with HPCA agent version 5.1 installed

Hi, Most probably the 5.1 Agent is not supported on Windows 7. Use the HPCA 7.8 or later Agent. Best Regards, Shanti
Valued Contributor

Re: Problem deploying an application to a Windows 7 OS with HPCA agent version 5.1 installed

Hi,

 

as Shanti has said,if you are operating an earlier version of HPCA—5.11 or newer—you may install the HPCA 7.8 agent upon your managed devices, which should enable basic HPCA functionality with the exceptions of Patch Management and OS Management

 

For further informration, please check this knowledge article:

CAE Windows 7 Support Statement - http://support.openview.hp.com/selfsolve/document/KM867233 

 

Best regards,

Maria

Highlighted
Frequent Advisor

Re: Problem deploying an application to a Windows 7 OS with HPCA agent version 5.1 installed

Thank you both for replying.  I am aware that version 5.1 does not support Windows 7.  We are moving towards the upgrade as I had mentioned, but I was curious if anyone knew of a work around I could employ as a temporary solution until 7.9 is production ready.

 

I'm not looking to utilize at 7.9 components like Patch, I am simply deploying zservices that have been captured using Packager.  Then deploying that package to a Windows 7 OS with a  5.1 agent.  Where some applications are failing is when they have to deploy files to locations like C:\Windows\winsxs which is controlled by TrustedInstaller.

 

If anyone has some ideas for me I would appreciate it.