Data Protector Support and News Forum
Showing results for 
Search instead for 
Do you mean 

RDS using all memory

Trusted Contributor Trusted Contributor

RDS using all memory



I have a problem in that the RDS service on the cell manager uses up all of the memory when an IDB backup is run and won't release it until the RDS service is restarted.  This happens on both of the cell managers that I use.  Eventually the entire server grinds to a halt and requires the RDS service restarting.


Both cell managers are DP7.01, Win2K8R2 with 32GB RAM.  They have both been upgrades from v6.11 and are patched up to the latest level for v7.01.


Can anyone tell me whether this is a known issue and if so, is there a fix?


Many thanks,



Kudos gratefully accepted - How to assign...
HPE Expert

Re: RDS using all memory

I found a couple of  lab cases that references this problem


This problem is well known for intensive data driven applications running on Windows Server Family operating  systems.


The problem is in the behaviour of Microsoft Windows's "Dynamic Cache Service", but it is not clear if an adjustment should be made to "Dynamic Cache Service" or to Data Protector's setting of an option that "Dynamic Cache Service" uses.  Possibly both are needed.


Regarding Windows "Dynamic Cache Service", I read:
Document ID: c03117812
Version: 1
CUSTOMER ADVISORY: Configuring the cache usage on Windows 2008 R2 system

as well as MS articles and blogs and forums and QuIXy cases about Windows "Dynamic Cache Service".


There was a test binary issued, but, I don't know if it changed anything in Data Protector, or enabled you to download Dynamic Cache Service


You can try upgrading to DP 7.03, with no guarantee that this will fix the problem


Unless someone in the Forum has another idea, I advise that you open a Response Center case about this issue, and make reference to







Occasional Visitor

Re: RDS using all memory

This is a known issue with MS windows 2008 R2 due to their change in the Cache manager



UNDER the DPHOME\db40\datafiles\catalog


You will find the RDMSERVER.ini


under the [Engine] 


add the line




Save the file and restart the services...