Data Protector Support and News Forum
Showing results for 
Search instead for 
Do you mean 

Velocis Daemon (RDS) is not running.

Regular Advisor

Velocis Daemon (RDS) is not running.

This is the detail info:

On Unix Cell Manager:
Check to be sure that the Velocis Daemon (RDS) is running. Stop the Cell
Manager (using the omnisv.sh -stop command) and restart the Cell Manager
(using the omnisv.sh -start command).

I have done this but get the same error. The system had gone down and back up prior to this error.
11 REPLIES
Regular Advisor

Re: Velocis Daemon (RDS) is not running.

More info:

# more /u02/omniback/var/log/RDS.log
[17-Aug-02 13:11:48] CATPATH variable /var//opt/omni/db/catalog
[17-Aug-02 13:11:48] RECOVERY REQUIRED
[17-Aug-02 13:11:48] RECOVERY: change log file=/var//opt/omni/db/syslog/rAAACSPG.chg
[17-Aug-02 13:11:48] RECOVERY: pass 1, discover last checkpoint address
[17-Aug-02 13:11:48] RECOVERY: checkpoint address=86861, EOF=102897
[17-Aug-02 13:11:48] RECOVERY: pass 2, build REDO and UNDO list
[17-Aug-02 13:11:48] RECOVERY: pass 3, redo 3 transactions
[17-Aug-02 13:11:48] RECOVERY: REDO transaction 6382
[17-Aug-02 13:11:48] RECOVERY: REDO transaction 6383
[17-Aug-02 13:11:48] RECOVERY: REDO transaction 6384
[17-Aug-02 13:11:48] RECOVERY: opened database ob2cdb
[17-Aug-02 13:11:48] RECOVERY: opened database
[17-Aug-02 13:11:48] ***Fatal runtime library error***
[17-Aug-02 13:11:48] Specific problem: Unable to read database name from catalog
[17-Aug-02 13:11:48] Task #: 1, User name: servertask
[17-Aug-02 13:11:48] Current database handle: 65538, name: ob2cdb
[17-Aug-02 13:11:48] Function Entry: RUNTIME\DBFCNS.C:345
[17-Aug-02 13:11:48] Error Location: RUNTIME\RECOVER.C:664
[17-Aug-02 13:11:48] ***********************************
[17-Aug-02 13:11:48] * Please report this condition to *
[17-Aug-02 13:11:48] * your software supplier. *
[17-Aug-02 13:11:48] ***********************************
[17-Aug-02 13:11:48] Exiting to operating system
Honored Contributor Honored Contributor

Re: Velocis Daemon (RDS) is not running.

Mark,

Just in case something is hanging:

Try doing the ~/omnisv.sh stop and the ~/omnisv.sh start again. But before you do anything else run:
/opt/omni/sbin/omnidbutil -clear

and then confirm that only the daemons associated with OBII are running...and only 1 instance of each.

Just something to start with,
Rita
Regular Advisor

Re: Velocis Daemon (RDS) is not running.

Rita,

# /opt/omni/sbin/omnidbutil -clear
Clearing running sessions ...
[12:1166] Velocis daemon error - the daemon is probably not running.
# /opt/omni/sbin/omnisv.sh stop
HP OpenView OmniBack II daemons successfully stopped.
# /opt/omni/sbin/omnisv.sh start
HP OpenView OmniBack II daemons successfully started.

I am still getting the same error.
Honored Contributor Honored Contributor

Re: Velocis Daemon (RDS) is not running.

Mark,

Run /opt/omni/sbin/omnisv.sh status

What does it say?

Rita
Regular Advisor

Re: Velocis Daemon (RDS) is not running.

HP OpenView OmniBack II Cell Report
-----------------------------------
Cell Manager daemon up and running [15587].
Media manager daemon up and running [15586].
Raima Velocis server not running.
Triggering of backups enabled.
Sending of traps disabled.
Honored Contributor Honored Contributor

Re: Velocis Daemon (RDS) is not running.

OK...Let's try this:

First - check your /var/opt/omni/log/RDS.log for details...it may shed some light on the matter. If need be attach a copy of this.

Next - 'the book' I believe suggests ensuring that all your db files are there. So take a look at /var/opt/omni/db and compare those files to your /opt/omni/newconfig/var/op/omni/db files and make sure nothing is missing.

Send me an email when your done...rworkman@wvbep.org or I'll just check back in a bit to see if you've responded.

Be back soon !
Rita
Honored Contributor Honored Contributor

Re: Velocis Daemon (RDS) is not running.

Mark...

A question -

What was the last OBII thing that finished???

I am obviously leaning towards the possibility that your OBII database is corrupted...

Check this:
/opt/omni/sbin/omnidbcheck

Rita
Regular Advisor

Re: Velocis Daemon (RDS) is not running.

Rita,

The log info is up earlier.

# .//opt/omni/sbin/omnidbcheck
[12:1166] Velocis daemon error - the daemon is probably not running.

Regular Advisor

Re: Velocis Daemon (RDS) is not running.

Here is the newconfig info
Honored Contributor Honored Contributor

Re: Velocis Daemon (RDS) is not running.

OK...went back and read above closer..

Your database is more than likely corrupted.
"..
You can try ~/omnidbcheck -fix and see if they will rebuild your db key files.

If that doesn't work you can try to Restore your database from last good OB_database backup tape. Or if you have done a recent omni_write, you could restore from there by running omni_read to rebuild everything.

See if you able to do resolve your issue with one of the above...if not then you may be in for something a bit more drastic. But my db has gotten corrupted and I was able to do a restore of it from my last tape and get it back...just took forever to restore it from tape.

Rita

Regular Advisor

Re: Velocis Daemon (RDS) is not running.

Thanks Rita for the help. I have had to restore the db before.

./omnidbcheck -fix
[12:1166] Velocis daemon error - the daemon is probably not running.

Mark