Databases
Showing results for 
Search instead for 
Do you mean 

incomplete startup packet in postgresql conf on HP-UX 11i IA64 server

Highlighted
Occasional Collector

incomplete startup packet in postgresql conf on HP-UX 11i IA64 server

Hello,

 

I've a PHP 64bit application that runs on 64bit apache on HP-UX 11.23 Itanium 64bit server.  I'm having lot of troubles with PHP connecting to postgreSQL database that is already setup.. 

 

I can connect to psql from terminal and also PHP (in CLI mode) is able to connect to postgreSQL.. 

 

But, from CGI (web), application exits saying couldn't connect to postgreSQL database ..  In the database log, i see errors like:

 

2013-03-27 09:30:21 EDT DEBUG: forked new backend, pid=8728 socket=9
2013-03-27 09:30:21 EDT [unknown] LOG: incomplete startup packet
2013-03-27 09:30:21 EDT [unknown] DEBUG: proc_exit(0)
2013-03-27 09:30:21 EDT [unknown] DEBUG: shmem_exit(0)
2013-03-27 09:30:21 EDT [unknown] DEBUG: exit(0)
2013-03-27 09:30:21 EDT DEBUG: reaping dead processes
2013-03-27 09:30:21 EDT DEBUG: server process (PID 8728) exited with exit code 0
2013-03-27 09:30:21 EDT DEBUG: forked new backend, pid=8729 socket=9
2013-03-27 09:30:21 EDT [unknown] LOG: incomplete startup packet
2013-03-27 09:30:21 EDT [unknown] DEBUG: proc_exit(0)

 

Can somebody advise how to fix the error "incomplete startup packet" ??   

 

Also, i noticed that PHP to PGSQL connection works for the first time when apache is started up.. And then it exits after the subsequent connections..  

 

 

any quick help please?

 

 

Thanks...