Functional Testing/QTP Support Forum Knowledge Base
Showing results for 
Search instead for 
Do you mean 

Can objects customised using QTP 11 be resused in QTP 10 ?

by on ‎05-23-2013 10:04 AM


I have QTP 11 in one machine and QTP 10 in another machine. Since the object properties got changed in the application I have updated the OR using QTP 11.  But when I tried to use the same OR from QTP 10, the object properties for many of the objects disappeared. 


QTP 11 resources/scripts are not backwards compatible for use in QTP 10.

Karthiksrinivas on ‎04-28-2015 11:59 PM

Kevin, Did u tried adding object from QTP10 version and try to identify from QTP11. I think back word will not give solution, u need to try with upwords version. Means Add the Object in QTP 10 and test on QTP11 i think this will work.

Shalabh Dixit on ‎05-13-2015 04:09 AM

I think most of the properties remains the same in QTP 11 & 10 version. They differ only if somebody have used either of the following object identification techniquues in OR using QTP 11


1. xpath Identification

2. Visual Relation

3. CSS Path


These are the major enhancements that were added in QTP 11 version onwards. I think if the user have not used either of these identification techniques while creating OR in QTP 11 then that particular OR should be working with QTP 10 version as well.




Shalabh Dixit

UFT004 Monday


We are using UFT11.5 with .net addin , .net framework 4.5.2. I am trying to automate one .net windows based application where objects are identified as windows objects, where they are expected to be identified as .swf objects. I tried spying with .net spy it is saying, these are not .net objects. I tried all the possible options like

selecting record and run settings as "run on any opened windows based appication"

selecting .net adding with wpf etc.

These objects are windowsform10 objects. when application opened before opening UFT, these are identified. but these kind of forms wouldbe displayed during navigation of the application. I am unable to find the root cause of the issue. Please suggest is there any patch needed or any other options available to overcome this issue.


the following the code it is generated when tried to record

Window("Create Scheme_2").WinObject("").Click 105,36 
Window("Create Scheme_2").WinObject("").Type "te"

Window("Create Scheme_2").WinObject("Next >").Click 24,8