Showing results for 
Search instead for 
Do you mean 

Apache/Weblogic Error

Occasional Visitor

Apache/Weblogic Error


We have an application that is deployed on the Apache2.0.59 web tier and the Application layer is deployed on Weblogic 9.1 version, DB used is Oracle10g.

Currently we have this application deployed just on one Managed Server in Weblogic and the go forward solution is to deploy this application on all servers in the cluster and across cluster to manage failover.

So first to test the session persistence for this application within a single cluster I have deployed this application on all servers in a cluster and configured WebLogicHost to use the Load Balancer URL in Apache.

This configuration works if all the servers in the cluster are running but if I intend to stop one server in the cluster the next request from the client is not routed to the next available server but instead it route it to the same server which has been stopped and I get the following error
"Failure of server APACHE bridge:

No backend server available for connection: timed out after 10 seconds or idempotent set to OFF. "

Also if I refresh the page I am allowed to continue my session but again after few mins I am displayed the same error message. So I am not sure if I have to do any more configuration either in the Weblogic/Apache server to acheive the Session replication within cluster.

Kindly advice and do let me know if you need any specific configuration details.

Exalted Contributor Exalted Contributor

Re: Apache/Weblogic Error


Diagnostic step 1.

Find the error in the logs.

Weblogic has a log file, find it and check it.

Apache has error_log file, there may be something there.

I'd check the original documentation that shipped with Weblogic and see that the configuration was done according to guidelines.

Steven E Protter
Owner of ISN Corporation
Occasional Visitor

Re: Apache/Weblogic Error


I checked the apache error logs I could only see the below messages related to my application

[Thu Sep 25 05:50:08 2008] [warn] RSA server certificate CommonName (CN) `' does NOT match server name
[Thu Sep 25 05:50:09 2008] [notice] BEA plugin build date/time: Jul 25 2008 14:06:55. Change Number: 1136334
[Thu Sep 25 05:50:10 2008] [warn] RSA server certificate CommonName (CN) `' does NOT match server name

So do you think if this error message has any relation to my main problem.