General
Showing results for 
Search instead for 
Do you mean 

HP-UX 11i v1 screen capture, OpenGL problem.

SOLVED
Go to Solution
Advisor

HP-UX 11i v1 screen capture, OpenGL problem.

Hello everyone!

I'm using XnView to make screenshots in HP-UX. This program works great but! It has problem taking screenshots of windows where OpenGL is running. The image get really fuzzy.
See picture below:
http://www.h07.org/~luka/kaseta_bad.jpg

it should look like this:

http://www.h07.org/~luka/kaseta.jpg

The same thing happens if i take screenshot with xwd.

The the CAD application i'm using is UGS I-DEAS.

Is there maybe any X Window setting that could fix this problem?

Thanks for any help i will assign points!
8 REPLIES
Honored Contributor Honored Contributor

Re: HP-UX 11i v1 screen capture, OpenGL problem.

XnView is designed for native PC video but your Xwindow emulator may be manipulating the video in a very different way. You can try a different emulator, check with XnView support, try the best PC screen capture tool called SnagIT, or capture the window on the HP-UX side with xwd and then convert the file format to a PC format. You might also play with the emulator video settings -- look for Pseudo Color, True Color, etc.
Honored Contributor Honored Contributor

Re: HP-UX 11i v1 screen capture, OpenGL problem.

Hi,

'screencapture' was a fine tool in HP-UX 10.20
You should try to find it.
I've copied it to my 11i ws it's working great.
Or make the pictures in ideas itself?

Volkmar
*** Say 'Thanks' with Kudos ***
Advisor

Re: HP-UX 11i v1 screen capture, OpenGL problem.

xwd makes the same fuzzy image as xnview.
I don't know why is such a problem in HP-UX to make screenshots when OpenGL app is running.

On IRIX this works really well.

Is there any X Window expert which knows the solution for this?
Advisor

Re: HP-UX 11i v1 screen capture, OpenGL problem.

I don't have any workstation running 10.20 so i can't get screencapture :(
Honored Contributor Honored Contributor

Re: HP-UX 11i v1 screen capture, OpenGL problem.

I *think* it's freeware :-)
*** Say 'Thanks' with Kudos ***
Honored Contributor Honored Contributor

Re: HP-UX 11i v1 screen capture, OpenGL problem.

Btw. Luka:
You shouldn't use two logins ;-)

http://forums1.itrc.hp.com/service/forums/publicProfile.do?userId=BR917794

http://forums1.itrc.hp.com/service/forums/publicProfile.do?userId=BR935050

You can ask a moderator to send you a new password, if you can't login to one of them

V.
*** Say 'Thanks' with Kudos ***
Honored Contributor Honored Contributor

Re: HP-UX 11i v1 screen capture, OpenGL problem.

screencapture was part of the MPOWER product bundle and as such was not free, last ported to hpux 11.00 as I remember and would be on the application CD's.

However I'm wondering if your problem could be with overlay planes within the OpenGL application, ie you are only capturing the standard Xserver visual, not those being displayed over it.

Perhaps imagemagick (freeware) maybe of some use in this situation. Personally I'd look into whether this could be done within the IDEAS s/w itself.
Advisor

Re: HP-UX 11i v1 screen capture, OpenGL problem.

V. Nyga Thank you big time for screencapture!!! i can now make screenshots of OpenGL running! :)

I have only one account here. i don't know why sometimes my last name is displayed with 'c' or 'Ä '.

Yeah i can make screenshots in I-DEAS with build-in print function. But their quality sucks.