HPE BladeSystem Server Blades
Showing results for 
Search instead for 
Do you mean 

BL460c G7 blade Factory Reset to Default Settings

Highlighted
Trusted Contributor

BL460c G7 blade Factory Reset to Default Settings

Al was looking to reset a blade to factory settings:

 

**************

 

I remember using this procedure on BL460G1 blades, but confirmation for 460G7 is really appreciated:

 

Set maintenance dip switch 6 to on position

Power up blade

Shutdown blade

Set switch back to off position

 

iLO should be back to factory settings (no IP Addresses, user added login/passwords, etc…).

 

Am I missing something?

 

*************

 

Input from Dave:

 

**************

 

There should be a label on the Blade cover that gives all settings.

 

1                     iLO2 security Overide

2                     Configuration Lock

5              Password Disable

6              Reset Configuration                ( ROMBIOS)

 

Others are reserved.

 

****************

 

And from Will:

 

****************

 

I believe the #6 DIP switch performs a clear CMOS which will clear the ROMBIOS.  Also, when the #1 and #6 DIP are used together, they perform a “harder” reset on the blade; but I would not say it’s a factory reset.

 

When I need to reset blade to factory, I usually use the OA CLI and drop an HPONCFG script.  Here are the scripts I use:

 

####Reset iLO2 to factory settings####

 

HPONCFG “Insert Blade Bay Number”  << end_marker

<RIBCL VERSION="2.0">

  <LOGIN USER_LOGIN="Dontcare" PASSWORD="UsingAutologin">

                <RIB_INFO MODE="write">

                                <FACTORY_DEFAULTS/>

    </RIB_INFO>

  </LOGIN>

</RIBCL>

 

####Reset iLO3 to factory settings####

 

hponcfg “Insert Blade Bay Number” << @

 

<RIBCL VERSION="2.0">

  <LOGIN USER_LOGIN="Dontcare" PASSWORD="UsingAutologin">

    <RIB_INFO MODE="write">

    <FACTORY_DEFAULTS/>

    </RIB_INFO>

  </LOGIN>

</RIBCL>

 

@

 

Just change the highlighted areas to match your bay numbers.  Good luck!

 

***********

 

Any other input for Al?

 

4 REPLIES
HPE Pro

Re: BL460c G7 blade Factory Reset to Default Settings

The method provided by Will just resets iLO and not the the BIOS. To reset BIOS to defaults you have to flip switch 6 or go into RBSU and select the option to reset to factory default.




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Occasional Advisor

Re: BL460c G7 blade Factory Reset to Default Settings

I can't reset using that hpomcfg sctript, because i imported a bad certificate on my ilo3.

 

Is there any other way to reset ilo3 completly so it forgets the certificate, etc.. ?

HPE Pro

Re: BL460c G7 blade Factory Reset to Default Settings


Ricardo M. Esteves wrote:

I can't reset using that hpomcfg sctript, because i imported a bad certificate on my ilo3.

 

Is there any other way to reset ilo3 completly so it forgets the certificate, etc.. ?


During POST Press F8 when prompted to get into iLO configuration. There is an option to reset to factory default




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Occasional Advisor

Re: BL460c G7 blade Factory Reset to Default Settings

I was able to reset the ilo removing the battery and waiting a fiew minutes.