HPE BladeSystem Virtualization
Showing results for 
Search instead for 
Do you mean 

Is the ESX5.1 Emulex BE2Net driver downgrade required when NOT using FCoE?

Regular Advisor

Is the ESX5.1 Emulex BE2Net driver downgrade required when NOT using FCoE?

We have a number of HP BL465c G7 blades running ESXi 5.0.  They have the NC551i Emulex based flex-10 NIC.  Per the HP recommendations earlier this year we updated the drivers to 4.1.334.0.

 

We're looking at upgrading these to ESXi5.1 with the HP ISO.  However, according to the recipe file, and the HP customer advisory C03533196, the recommended BE2Net driver is 4.1.255.11-1.  Since the upgrade won't "downgrade" files, to put it at the correct version the workaround is to do a manual VIB install on each blade.    The "resolution" section says that "a future release" of the ISO will fix this, but it's been over 2 months and they still haven't fixed it.

 

According to the advisory, the downgrade is required due to interactions with the fiber channel driver (lpfc) when using FCoE. 

 

However, we're not using FCoE on this interface and have no plans to.  We have dedicated QLogic fiber channel card for the SAN communications.  The Emulex BE2Net driver is only used for networking.

 

Since we're not using the Emulex for FCoE, do I still need to downgrade the BE2Net driver?

 

 

4 REPLIES
HPE Pro

Re: Is the ESX5.1 Emulex BE2Net driver downgrade required when NOT using FCoE?

hi,

the advisory that you are checking was Last Updated: 2012-10-18
there are some new recipe the last one was released in frebruary and there are new FW/drivers recommendations for your case:
NC551i be2net ESXi 5.0/5.1 - 4.2.327.0 (driver) 4.2.401.6 (FW)
http://vibsdepot.hp.com/hpq/recipes/

http://vibsdepot.hp.com/hpq/recipes/February2013VMwareRecipe5.0.pdf
HPE Pro

Re: Is the ESX5.1 Emulex BE2Net driver downgrade required when NOT using FCoE?

Hi Mike,

Find the advisory on upgrading to ESXi 5.1 (Click here for Document ID: c03533196), which states when upgrading to ESXi 5.1 from earlier ESXi version the be2net driver might not get upgraded and as per the document ESXi 5.1 has inbox driver which is a recommended version.

The present HP recommended version are as below.
Drivers:
NC551i be2net ESXi 5.0/5.1 - 4.2.327.0
NC551i be2iscsi ESXi 5.0/5.1 - 4.2.324.12
NC551i lpfc ESXi 5.0/5.1 - 8.2.4.141.55
Firmware:
4.2.401.6

Click here for latest HP VMware Recipe Dcoument.

These two drivers are developed and validated as a pair. When the drivers are not in synch, unexpected behavior may be experienced. My personal opinion this applies only when FCoE is configured, otherwise I do not think it should be a problem.

Thanks,

I work for HP
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details

Occasional Visitor

Re: Is the ESX5.1 Emulex BE2Net driver downgrade required when NOT using FCoE?

was looking for recommended document on firmware and drivers which can be installed on hp proliant servers running vmware operation system 

 

thank you for info

Super Advisor

Re: Is the ESX5.1 Emulex BE2Net driver downgrade required when NOT using FCoE?

Thanks for the reply, does this firmware upgrade is the only firmware update needed for ESXi 5.1 installation on the Blade servers affected ?

 

or do I need to upgrade the other firmware to be able to proceed ?