HPE Service Manager / Service Center Support and News Forum
Showing results for 
Search instead for 
Do you mean 

SSL on Mobility & Windows Client

SOLVED
Go to Solution
Frequent Advisor

SSL on Mobility & Windows Client

We are running Service Manager 9.32. Are you able to have SSL enabled on the Application Server and the other web based portions (IE: Web Tier, SRC, & Mobility) but not force the Windows (Thick) Client to use SSL?

 

I reviewed the various parameters in the sm.ini, could this work if I have ssl:1 and ssl_reqClientAuth:0  ??

 

Any advice or assistance would be appreciated.

Thanks,

Shawn

1 ACCEPTED SOLUTIONS
Respected Contributor

Re: SSL on Mobility & Windows Client

Hi,

 

Please see how I did it:

sm.ini

 

# ServiceManager Initialization file
# (c) Copyright 2008 Hewlett-Packard Development Company, L.P.
# Configuration Modified Date:2/12/13 5:35 PM
shared_memory:32000000
log:../logs/sm.log
system:13080
httpPort:13080
#sslConnector:0
httpsPort:13443
sqldictionary:sqlserver
[sqlserver]
sqldb:SM9.21
*sqllogin:5A4DFAA7B424195A6786F075F4451D53
plugin0:kmplugin.dll
keystoreFile:server.keystore
keystorePass:serverkeystore
truststoreFile:cacerts
truststorePass:changeit
ssl_trustedClientsJKS:trustedclients.keystore
ssl_trustedClientsPwd:changeit
ssl_reqClientAuth:1
sslConnector:1

 

sm.cfg

#
# start a Service Manager listener
#

#sm

sm -httpPort:13080 -sslConnector:0
sm -httpPort:13081 -sslConnector:1 -httpsPort:13443 -ssl:1

# When unable to start the server as a service
# uncomment the following line to produce an output
# file which may contain some information from the
# Java JVM.
#cmd /c "sm" > C:\\process_stdout 2>&1

 

#
# start background schedulers
#

sm system.start

 

 I use 13080 for Windows client connection and 13081 for the Web client.

If you find this post useful/helpful click the Kudo star on this post!

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
2 REPLIES
Respected Contributor

Re: SSL on Mobility & Windows Client

Hi,

 

Please see how I did it:

sm.ini

 

# ServiceManager Initialization file
# (c) Copyright 2008 Hewlett-Packard Development Company, L.P.
# Configuration Modified Date:2/12/13 5:35 PM
shared_memory:32000000
log:../logs/sm.log
system:13080
httpPort:13080
#sslConnector:0
httpsPort:13443
sqldictionary:sqlserver
[sqlserver]
sqldb:SM9.21
*sqllogin:5A4DFAA7B424195A6786F075F4451D53
plugin0:kmplugin.dll
keystoreFile:server.keystore
keystorePass:serverkeystore
truststoreFile:cacerts
truststorePass:changeit
ssl_trustedClientsJKS:trustedclients.keystore
ssl_trustedClientsPwd:changeit
ssl_reqClientAuth:1
sslConnector:1

 

sm.cfg

#
# start a Service Manager listener
#

#sm

sm -httpPort:13080 -sslConnector:0
sm -httpPort:13081 -sslConnector:1 -httpsPort:13443 -ssl:1

# When unable to start the server as a service
# uncomment the following line to produce an output
# file which may contain some information from the
# Java JVM.
#cmd /c "sm" > C:\\process_stdout 2>&1

 

#
# start background schedulers
#

sm system.start

 

 I use 13080 for Windows client connection and 13081 for the Web client.

If you find this post useful/helpful click the Kudo star on this post!

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Highlighted
Frequent Advisor

Re: SSL on Mobility & Windows Client

Alex,

Thanks for your reply. With reviewing your settings I was able to turn on SSL for the Mobility & Web Tier clients while keeping the Windows Client as non SSL.

Thanks!