HPE StoreVirtual Storage / LeftHand
Showing results for 
Search instead for 
Do you mean 

Hyper-V VSA Bug

Occasional Visitor

Hyper-V VSA Bug

I've been playing around in my lab with the VSA for Hyper-V prior to rolling it into production.  I've discovered a rather evil bug that I wanted to see if someone else could replicate.  I can duplicate this problem non-stop, so it's either my particular configuration, or I'm doing something wrong.


Brand new, Windows Server 2008 R2 SP1.  Create a basic VM just to verify it all works. (it does)


Install VSA for Hyper-V.


If the VSA installation fails for any reason, it will delete the entire Hyper-V folder out of C:\programdata\microsoft\windows (the default hyper-v installation folder).  I've had this happen at least 5 or 6 times now, the latest was because I tried to create a VHD to a path that didn't exist.  Thankfully, after the previous time I got wise and backed up the Hyper-V folder before running the VSA installation, so all I had to do was copy it back.


This is kind of nasty though, if it's not just me I can imagine the wailing and gnashing of teeth that would occur in a production environment.


Also, can we make the install smarter so if the path doesn't exist during installation it gets created?  Minor detail I know, but I can't remember the last time software installation would die instead of creating a path that was specified but didn't exist.


(note: all this was done on the machine itself, logged in as a local administrator)

Occasional Visitor

Re: Hyper-V VSA Bug

Actually it looks like it deletes whatever folder you install to if it fails. I had a folder called C:\Hyper-V with a single VM created inside of it and after it failed it removed the entire C:\Hyper-V folder. (doesn't go into the recycle bin either)