IMC
Showing results for 
Search instead for 
Do you mean 

Lost Admin Password

SOLVED
Go to Solution

Lost Admin Password

[ Edited ]

Hi Everyone,

 

Is there anyway of resetting the admin password from a other user in the admin group.

Or would we need to backup iMC databases, uninstall iMC and then reinstall iMC again?

 

Thanks

 

iMC 5.2

Windows 2008 R2 x64

1 ACCEPTED SOLUTION
Honored Contributor

Re: Lost Admin Password

Check out this thread here: http://www.netopscommunity.net/forums/-/message_boards/message/47737?p_p_auth=gVeyXa14&_19_redirect=...

 

No guarantees if it will work with 5.2, but it is worth a go.

17 REPLIES
Honored Contributor

Re: Lost Admin Password

IMC stores the password hash in the DB. If you've got DB access, you could try overwriting the hash with the hash of a known password

Re: Lost Admin Password

Thanks For that,

Would you happen to know were and in which table that could be found?

 

Honored Contributor

Re: Lost Admin Password

Check out this thread here: http://www.netopscommunity.net/forums/-/message_boards/message/47737?p_p_auth=gVeyXa14&_19_redirect=...

 

No guarantees if it will work with 5.2, but it is worth a go.

Re: Lost Admin Password

Much Thanks.

 

That Worked for iMC 5.2

 

 

Highlighted
Honored Contributor

Re: Lost Admin Password

Awesome! It's something that I've done in a lab, but it's nice to know that it works when it's really needed.

Member

Re: Lost Admin Password

He,
 
I just read your post,
I have a similar problem.

By mistake, the privileges of the administrator group have changed. So I have more access to the menu:
system - operator management - operator group

Is what I can find it?

or how to restore db?

Please help me!
Occasional Advisor

Re: Lost Admin Password

CG46 did you find an answer? I have had a similar thing happen.  I can't access the site mentioned above so I am not sure where to look in the database.

Honored Contributor

Re: Lost Admin Password

config_db, tbl_plat_operator contains a list of usernames/passwords.

 

I have seen this situation before, where people think that they've lost admin privileges, but it's because they're looking at the standby system. Do you have an active/standby setup?

Occasional Advisor

Re: Lost Admin Password

Thanks for the reply and I will look at the database now.

 

One question though how do I know if I have active/standby setup?

Honored Contributor

Re: Lost Admin Password

Well usually you know if you've installed either one or  two servers.

 

Standby system has fewer menu options, and there's many things you can look at, but not change - exactly as you are describing.

 

Look at the Deployment Monitoring Agent, and see if it's set up to use Auto Backup from the primary, with Auto Restore on the secondary.

 

 

Occasional Advisor

Re: Lost Admin Password

Sorry I get what you mean now (Terminology) We only have the one server.  

 

I have looked in that table and I can see the admin users and I am able to change settings and password hashes.

 

However I am still in the situation where the admin users don't have full access to the system.

 

I have a backup of the database before I upgraded, if I was to uninstall and then install V7 from scratch could I use the database backup or is the database modified in the upgrade?

Honored Contributor

Re: Lost Admin Password

Yes, the DB gets modified during upgrade.

 

Depending on how important your data is/how much time and money you have, I would be looking at one of more of these courses of action:

 

1/ Roll back the upgrade.

2/ Log support case, or engage local technical resource to investigate

3/ Dig deeper into the DB yourself, look at  what's going on with roles, etc. Check that system is not set to Auto-Restore.

4/ Roll back the upgrade, and try upgrade again.

Occasional Advisor

Re: Lost Admin Password

Thanks for getting back so quick.

 

I have a case logged with HP however they seem very slow to even come back to acknowledge me.

 

We are a School so money is an issue we were very lucky to get iMC .

 

I have checked and "enable auto backup and recovery" is not checked.

 

My iMC install is on a VM so I think I will go to an earlier snapshot.  Shame I really wanted to understand what had happened

Honored Contributor

Re: Lost Admin Password

I'd like to know what's happened too! But yeah, sometimes it's better to take the path of least resistance.

In classic computer engineering style, roll back, run the upgrade again, and see if it works this time. (Yeah, not a lot of help, I know).

If you want to, you could keep a separate clone of the broken system, for further digging later.
Occasional Advisor

Re: Lost Admin Password

Thats is exactly what I have done saved a vm to put in a test enviroment.

 

I have restored a snapshot and all is fine however I am back on 5.2 so I will now try again.

Honored Contributor

Re: Lost Admin Password

One thing I forgot to mention - if you aren't already doing it, go straight to 7.0 E0202. Good thing is you don't need to go to 7.0 base + patch.

Occasional Advisor

Re: Lost Admin Password

[ Edited ]

Thanks downloading now I will update how its goes this time.