IT Asset Manager / Connect-IT Support and News Forum
Showing results for 
Search instead for 
Do you mean 

Asset Manager 5.12 Web Issue

Advisor

Asset Manager 5.12 Web Issue

I have recently upgraded from Asset Manager 5.11 to 5.12. I ran the upgrade script to upgrade the database from 5.11 to 5.12 (as per the documentation). I changed the path from "C:\Program Files\HP\Asset Manager 5.11" to "C:\Program Files\HP\Asset Manager 5.12" in the C:\tomcat50\conf\Catalina\localhost\AssetManager.xml and C:\tomcat50\conf\Catalina\localhost\AssetManagerWebService.xml file for Tomcat.

I can logon successfully using the client and the Automated Process Manager with NO ERRORS. When I try to pull up the web, I get this error: An error occurred during authentication: The AXIS engine could not find a target service to invoke! targetService is Head/Administration

I have even uninstalled EVERYTHING and re-installed from scratch following the directions to the "T". I am connecting to an Oracle database and I have migrated from Asset Manager 4.5 to 5.0 and from 5.0 to 5.01 then from 5.01 to 5.10 then from 5.10 to 5.11 with no problems so I am used to this process.

PLEASE HELP!!!
6 REPLIES
Super Advisor

Re: Asset Manager 5.12 Web Issue

Try to Again redeploy the AssetManager.xml and AssetManagerWebService.xml
Advisor

Re: Asset Manager 5.12 Web Issue

Resolved the issue. Database was corrupted. The issue had to deal with corrupt wizards. If you do a check definations of the web services and anything at all fails, you will get an AXIS error in the web portion of Asset Manager.
Advisor

Re: Asset Manager 5.12 Web Issue

Anything found in error when run: Check definitions of the Web services will give an AXIS error and render the web inoperable.
Occasional Visitor

Re: Asset Manager 5.12 Web Issue

Hi Jason,

I encountered the same error w/ some of the Wizards (written by PSO guys) after upgrading from AM 5.11 to 5.20.
I confirmed it's the Wizards using the "Check definitions of the Web services" tool. My question is how did you fix this issue?
Frequent Advisor

Re: Asset Manager 5.12 Web Issue

Hi Jason,

I also found the same error. Could you please share how to solve this problem?

TIA
Highlighted
Advisor

Re: Asset Manager 5.12 Web Issue

Its been a while, but I think I did something like a database repair, or I re-created the database from scratch and imported data back in. Its been a while...