ITRC Systems Insight Manager Forum
Showing results for 
Search instead for 
Do you mean 

SMH silent install problem

Contributor

SMH silent install problem

I've run into a problem when trying to install SMH via the "silent install" option on Windows 2008 servers.

 

I've already created the answer file (setup.iss) and execute from a command prompt (lauched as administrator):

 

setup.exe /s /f1setup.iss   (where setup.iss is located in the same directory as the setup file).

 

Nothing happens.   An hour glass flashes briefly, then . . . nothing.  No install, and more importantly, nothing's logging anywhere that indicates what's going on.   The same problem occurs if I include full paths in the above install line.

 

The smh_installer log that generates on the root of the system drive has NOTHING in it for today's date (it was already present from a previous install a couple of months ago).  The Windows application and system log have nothing for the time stamps when the install was initiated.

 

If I simply initiate the installer from outside of the command line and install the via the GUI, it works fine.  It's not a downgrade or same version install, as I'm going from 7.3.1.4 to 7.3.2.1

 

I haven't been able to track down any information about SMH's setup.exe command line parameters on the web. 

 

Any ideas?

 

 

2 REPLIES
Contributor

Re: SMH silent install problem

So . . . 

 

All documentation points to running the install with "setup.exe", which does indeed exist when you extract the files.

 

I noticed that there's also an "smhsetup.exe" in there too.   When I run with the install with THAT instance, it works.

 

Something so excruciatingly simple, yet lousy documentation sends you down the wrong path.

Occasional Visitor

Re: SMH silent install problem

U need to exctract the component Cpxx.exe to get the setup.exe file ..

the silent upgrade using the command setup.exe /s \f1 setup.iss worked on my windows box