ITRC Systems Insight Manager Forum
Showing results for 
Search instead for 
Do you mean 

Single Sign on doesn't work after System Management Homepage update

Frequent Advisor

Re: Single Sign on doesn't work after System Management Homepage update

Has anyone found a fix for this at all?  I have applied the fix from HP Advisory (adding certificates to C:\cafiles), but this does not work.  When I run Configure and Repair Agent, it says the following, although it imports the certificate with no issues

 

unable to login to the smh using certificate.................... [warning]

 

Thanks for any advise/help

Mel

Honored Contributor Honored Contributor

Re: Single Sign on doesn't work after System Management Homepage update

I have the same problem and have reverted to self-signed certs for the time being until I can do further testing. Self signed certs are against our company policy so if find this quite annoying! I had been using CA signed certs with  SIM 6.3 happily for years!

If my post was helpful please award me Kudos! or Points :)
Honored Contributor Honored Contributor

Re: Single Sign on doesn't work after System Management Homepage update

Unfortunately, I couldn't establish a trust relationship even with a self-signed cert! Also, I notice that if you do an import on the SMH of the SIM cert, it pulls in the previous SIM cert and not the current one! Best to paste in the cert in 64base format. This is such a pain.

If my post was helpful please award me Kudos! or Points :)
Advisor

Re: Single Sign on doesn't work after System Management Homepage update

Hey folks

 

Have somebody anything new? Did any case solve this problem?

 

nik

Occasional Visitor

Re: Single Sign on doesn't work after System Management Homepage update

HP released Customer Advisory for this problem, check it for more details

Frequent Advisor

Re: Single Sign on doesn't work after System Management Homepage update

Consolero posted that several months ago and many of us tried this. It does not fix the problem in first place and is not suitable for large installations.

Since HP stated that it will not be fixed in the future I think about using nagios instead.

Occasional Visitor

Re: Single Sign on doesn't work after System Management Homepage update

I have the same issue where it won't work self-signed on 7.2 SMH  clients. When I run a CRA it imports a previous 1024 cert and I get:

 

Unable to login to the SMH using certificate.................... [WARNING]
Check the system link configuration by going to "Options->Security->System Link
Configuration".

Occasional Visitor

Re: Single Sign on doesn't work after System Management Homepage update

As a follow-up to my post, I regenerated the SSO certs as 2048 and still nothing worked. I finally just re-installed the SIM and started a clean client DB since the certs were messing with RSA as well. I still got the same warning after all this. I seem to have narrowed it down to using:

 

HP Insight Management Agents for Windows Server 2003/2008 9.0.0.0.

 

If I use an older version then the CrA sets the trust and everything works fine again. I suspect something in the latest Mgmt Agent is causing the trouble. When I go back and try to downgrade some of the systems the install won't work. I guess this is a whole other issue I get to troubleshoot now. Please fix this HP.

Highlighted
Regular Advisor

Re: Single Sign on doesn't work after System Management Homepage update

I'm glad to see I'm not the only one having this issue. I'm dismayed to see this issue has been present from the first issue of SIM 7. I just recently did a clean install of SIM 7.2.0 build C.07.02.00.00 and have been having this issue on MANY of my servers. I'm also dismayed to hear the is no plans from HP for a fix. Although I haven't actually read that anywhere else but here at ITRC.

 

It's a giant pain in my *$$! And also a pain in the *$$ of my operations people who do not have local admin rights, so now I need to setup SMH Admin groups, another bigger pain in my *$$.

 

Can you tell I'm unhappy and Iv'e been using insight manager since the BMC Patrol days

Occasional Advisor

Re: Single Sign on doesn't work after System Management Homepage update

Same for me. We have to update the HP-SIM because we need the new version of the Virtual Connect Enterprise Manager (VCEM). After the Update about 320 Server have no SSO anymore and they are running in "blind flight" mode. So HP please fix this Problem soon.

 

Peter