Languages and Scripting
Showing results for 
Search instead for 
Do you mean 

Compiling on HPUX 11.31 Itanium with ldap library

SOLVED
Go to Solution
Highlighted
Occasional Advisor

Compiling on HPUX 11.31 Itanium with ldap library

I am compiling 32-bit program with ldap libray and error occur "ld: Mismatched ABI (not an ELF file) for -lldap50, found /iseprod/ivrshrt/.lib/libldap50.sl".

I have checked the library libldap50.sl is 32-bit.
$ file /iseprod/ivrshrt/.lib/libldap50.sl
/iseprod/ivrshrt/.lib/libldap50.sl: PA-RISC1.1 shared library -not stripped

Is there any other reason cause the error?
1 ACCEPTED SOLUTIONS
Acclaimed Contributor Acclaimed Contributor

Re: Compiling on HPUX 11.31 Itanium with ldap library

Besides having to match on bitness, you have to match on architecture.
Your shlib is PA, you need an Integrity version.
3 REPLIES
Acclaimed Contributor Acclaimed Contributor

Re: Compiling on HPUX 11.31 Itanium with ldap library

Besides having to match on bitness, you have to match on architecture.
Your shlib is PA, you need an Integrity version.
Occasional Advisor

Re: Compiling on HPUX 11.31 Itanium with ldap library

Thanks.
Cause the library was copied from old machine. Problem solved by using a IA64 version library.
Occasional Advisor

Re: Compiling on HPUX 11.31 Itanium with ldap library

Thanks.
Cause the library was copied from old machine. Problem solved by using a IA64 version library.