Languages and Scripting
Showing results for 
Search instead for 
Do you mean 

Perl 5.10.0 - 64 bit Error while make

Visitor

Perl 5.10.0 - 64 bit Error while make

Hi,

Having a problem when attempting to compile Perl 5.10.0/5.10.1 on an Itanium system.

Run the sh -Dprefix=/opt/perl-5.10.1 -Duse64bitall -Dcc=gcc -de which completes and then when I run a make I get the following error

 

              gv.o toke.o perly.o pad.o regcomp.o dump.o util.o mg.o reentr.o mro.o hv.o av.o run.o pp_hot.o

sv.o pp.o scope.o pp_ctl.o pp_sys.o doop.o doio.o regexec.o utf8.o taint.o deb.o universal.o xsutils.o glob

als.o perlio.o perlapi.o numeric.o mathoms.o locale.o pp_pack.o pp_sort.o  \

            miniperlmain.o opmini.o perlmini.o

ld: Unsatisfied symbol "cos" in file pp.o

ld: Unsatisfied symbol "exp" in file pp.o

ld: Unsatisfied symbol "log" in file pp.o

ld: Unsatisfied symbol "pow" in file pp.o

ld: Unsatisfied symbol "sin" in file pp.o

ld: Unsatisfied symbol "atan2" in file pp.o

ld: Unsatisfied symbol "floor" in file pp.o

ld: Unsatisfied symbol "frexp" in file sv.o

ld: Unsatisfied symbol "ceil" in file pp.o

ld: Unsatisfied symbol "fmod" in file pp.o

ld: Unsatisfied symbol "modf" in file pp_pack.o

ld: Unsatisfied symbol "sqrt" in file pp.o

12 errors.

collect2: ld returned 1 exit status

*** Error exit code 1

 

Stop.

Pelase Advice 

 

Regards,

Ramesh



 

9 REPLIES
Acclaimed Contributor Acclaimed Contributor

Re: Perl 5.10.0 - 64 bit Error while make

[ Edited ]
>when I run a make I get the following error

These unsats are all in libm.  Add "-lm" to your link line.
Visitor

Re: Perl 5.10.0 - 64 bit Error while make

HI Dennis,

I am not getting, do i need to add -lm in the configuration. What is -lm means ?

 

Regards,

Ramesh

 

Visitor

Re: Perl 5.10.0 - 64 bit Error while make

could you please tell me do i need give the "What libraries to use? " lm ?

Honored Contributor

Re: Perl 5.10.0 - 64 bit Error while make

Why oh why are you trying to build a perl that is almost 4 years old. 5.10.0 was released Dec 2007. The current release is 5.14.1 and should build out of the box on all HP-UX versions from 10.20 up to 11.31. I know, I do so every day.

 

A seconds reason not to build it yourself, is that prebuilt binaries are readily available, from HP Software, HP Porting center

and my own site 

 

Do you have a good reason to build your own (old) binary? 

Enjoy, Have FUN! H.Merijn
Acclaimed Contributor Acclaimed Contributor

Re: Perl 5.10.0 - 64 bit Error while make

>do I need to add -lm in the configuration. What is -lm means?

>do I need give the "What libraries to use?" -lm?

 

-lm tells the linker to link in libm.  I would have thought that was already there?

Visitor

Re: Perl 5.10.0 - 64 bit Error while make

Hi,

Client want to have 5.10.0, hence that i am trying build it.

 

Also i have tried with  prebuilt binaries but it taking 32 bit as default and could not configure for 64 bit. So i trying to build 64 bit on my own.

 

Regards,

Ramesh

 

 

 

 

Honored Contributor

Re: Perl 5.10.0 - 64 bit Error while make

The depots for 5.10.1 on my site include both 32bit and 64bit binaries. They are built with gcc-3.4.6.

The 5.10.0 binaries are (partly) built with gcc-4.2.2 which was not a very good gcc build.

 

If they still insist on 5.10.0, which is not a good sign, then you should check on your system if all that needs to be available for libm (the math library) is available, including! the header files.

 

Please specify the exact OS version you build on, so we could check what depot those are in. 

Enjoy, Have FUN! H.Merijn
Visitor

Re: Perl 5.10.0 - 64 bit Error while make

Hi Merijn,

This is the OS version

HP-UX suvsm01p B.11.23 U ia64 2592651913 unlimited-user license


This is the module  model
ia64 hp server rx6600 

 

Also, please let me know how to install 64 bit using depot.

 

Highlighted
Honored Contributor

Re: Perl 5.10.0 - 64 bit Error while make

# cd /tmp

# wget  http://mirrors.develooper.com/hpux/perl-5.10.1-11.23-ia64.sd.bz

# bzip2 -d  perl-5.10.1-11.23-ia64.sd.bz

# swinstall -s /tmp/ perl-5.10.1-11.23-ia64.sd perl.perl5-64

 

You can get wget here or use the browser of your choice to download the compressed archive and save it as binary file on the server. The depot for bzip2 is not compressed .

 

# cd /tmp

# wget  http://mirrors.develooper.com/hpux/bzip2-1.0.6-11.23.sd

# swinstall -s /tmp/ bzip2-1.0.6-11.23.sd bzip2

Enjoy, Have FUN! H.Merijn