Languages and Scripting
Showing results for 
Search instead for 
Do you mean 

Unable to install XML module

Occasional Visitor

Unable to install XML module

Hi all,
I am getting this problem while trying to use XML module in my script.

Script :
use XML::Simple ;
exit 0 ;

Error :
Can't locate XML/ in @INC (@INC contains: C:/PROGRA~1/MKSTOO~1/etc/perl
/lib C:/PROGRA~1/MKSTOO~1/etc/perl/lib C:/PROGRA~1/MKSTOO~1/etc/perl/lib/site_pe
rl .) at line 3.
BEGIN failed--compilation aborted at line 3.

When I tried to install its giving this error
Error: No valid repositories:
Error: 500 Can't connect to (connect: Unknown error)
Error: 500 Can't connect to (connect: Unknown error)

Pls suggest me how to get rid of this ?

Frequent Advisor Frequent Advisor

Re: Unable to install XML module

What version of Perl are you using.

My understanding is that most of the recent releases install this module by default.

The simplist option my just be to upgrade.

Answers to my questions elsewhere on this forum lead me to believe that many of the XML modules for Perl have significant bug fixes in later versions.

In my case getting an upgrade done was going to take too long so I wrote my own simple parser based on assumptions about the XML I had to look at.

I realise this is not very specific for your problem but I figured it may help a bit.
Behold the turtle for he makes not progress unless he pokes his head out.
Trusted Contributor Trusted Contributor

Re: Unable to install XML module

before you attempted to re-install did you removed perl. if not? I will swremove to get rid of any corrupt file. Then I will re0install perl with the default configuration.