Languages and Scripting
Showing results for 
Search instead for 
Do you mean 

What patches do I need for HP-UX 11.00?

Frequent Advisor

What patches do I need for HP-UX 11.00?

On an HP-UX machine, when I type uname -a, I get the following:

"HP-UX ono B.11.00 A 9000/871 2000957485 two-user license"

I am trying to write software in C++ and compiling with gcc 3.4.2. I am getting some very strange crashes when I run my programs, particularly in the multi-threaded portions. I do have QPK1100 installed on the computer, but I've been reading about other patches that I may possibly need. Do I need PHKL_27282? What about any others? My app just crashes for no apparent reason, stack traces come up with a NULL stack trace, and I've even tried Purify and Insure++. I fear that I have have bad libraries linked in. Any advice is appreciated.
6 REPLIES
Honored Contributor Honored Contributor

Re: What patches do I need for HP-UX 11.00?

Hi Maribeth,

Download and install the latest quality patch bundle.

http://www.software.hp.com/portal/swdepot/displayProductInfo.do?productNumber=QUALITYPACK

Best regards,
Robert-Jan

Frequent Advisor

Re: What patches do I need for HP-UX 11.00?

I already have the latest bundle, which from what I can tell is:

QPK1100 B.11.00.64.4 Quality Pack for HP-UX 11.00, March 2004

But my program crashes with the following:


"Pid 19469 killed due to trashed stack.
Pid 19469 was killed due to failure in writing the signal context."

I have no idea what is causing this. It is a multi-thread application and when I remove the calls to pthread_create, the app works fine. I'm wondering if I have a bad pthread lib or something to that effect. This is NOT a 64 bit machine.
Exalted Contributor Exalted Contributor

Re: What patches do I need for HP-UX 11.00?

http://www1.itrc.hp.com/service/patch/wrap.do?dest=/patch/jsp/WrapCPN.jsp&pageKey=patch.html.propatch

June 2004 or latest quality pack

http://www1.itrc.hp.com/service/patch/releaseIndexPage.do

From above link, get latest Hardware enablement, Bundle and quaterly.

Then run a patch assessment aand get anything else recommended.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Exalted Contributor Exalted Contributor

Re: What patches do I need for HP-UX 11.00?

Duh,

Everything else you need is here:

http://hpux.connect.org.uk/

The pre-requisites are listed on the products.

http://hpux.connect.org.uk/

Bad Mouse. Bad. Bad Mouse. Should have been one post.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Frequent Advisor

Re: What patches do I need for HP-UX 11.00?

Is there an email list that I can subscribe to that will notify me when critical patches are distributed?
Honored Contributor Honored Contributor

Re: What patches do I need for HP-UX 11.00?

Yes there is.

Click on the "» IT resource center" button on the left side of the screen (just below the HP Invent logo)

In the ITRC page you can choose the:
» subscribe to security bulletins & patch dig