Languages and Scripting
Showing results for 
Search instead for 
Do you mean 

error library /usr/lib/dld.sl

Super Advisor

error library /usr/lib/dld.sl

Hi there,
i have a Visualize B180L with installed hpux11.00 32bit environment. I've loaded the following patches and bundles:
64-bitDevLibs
HPUXEng32RT
J2559C (Jetadmin)
KernDev
QPK1100 (dec 2000)
UXCoreMedia
XSWGR1100 (march 2001)
XSWHWCR1100 (march 2001)
PHCO_25707 (libc cumulative patch)
A user is using a software on this ws, ise4.1.03, but he has an error (related to libraries while he's trying to run it). I've attached the error. How can I solve it?
Now i'm downloading the latest QPK bundle, what else?
Thanks
Tarek
8 REPLIES
Valued Contributor Valued Contributor

Re: error library /usr/lib/dld.sl

Hi,

I think the lib /local_com/PLD/xilinx_ise4.1/bin/hp/libTcl.sl
is wrong for your system.
Is it a lib from your application?
Check the lib with: file libTcl.sl

Ruediger
Honored Contributor Honored Contributor

Re: error library /usr/lib/dld.sl

Hi


What output does model give.


Steve Steel
If you want truly to understand something, try to change it. (Kurt Lewin)
Super Advisor

Re: error library /usr/lib/dld.sl

Yes, that library is of the software. I have another ws hp11, with same configuration (unless different patches), that is using the same software well.
Output of file libTcl.sl
libTcl.sl: PA-RISC2.0 shared library
model: 9000/778/B180L
Valued Contributor Valued Contributor

Re: error library /usr/lib/dld.sl

The other WS runs also with 32bit environment? May be your lib is a 64bit one.

Ruediger
Super Advisor

Re: error library /usr/lib/dld.sl

No, it's the same configuration, so 32 bit environment.
Valued Contributor Valued Contributor

Re: error library /usr/lib/dld.sl

And have you already checked the report filexcv150bg352-4_map.rpt ?

Ruediger

Super Advisor

Re: error library /usr/lib/dld.sl

That file isn't created!! I can't find it anywhere.
Highlighted
Honored Contributor Honored Contributor

Re: error library /usr/lib/dld.sl

Your B180 is a PA-RISC 1.1 system but your library is built for the PA-RISC 2.0 architecture. You need to obtain a version of your library libTcl.sl compiled for PA-RISC 1.1 (ie compiled with +DA1.1 or +DAportable).

From sched.models:

B180L 1.1e PA7300

Regards,
Steve