LoadRunner / Performance Center Knowledge Base
Showing results for 
Search instead for 
Do you mean 

VuGen - Scripting

by on ‎01-09-2014 08:52 AM


When I reply the script in VuGen, the following message is displayed in Output window -


Script_Name(LineNumber): Notify: Transaction "Transaction Name" ended with "Pass" status (Duration: 134.8640 Wasted Time: 2.0757).


What is this "Wasted Time"?

What is the significance of "Wasted Time"?



From the product help:

  • Time spent on activities whose purpose is to support test analysis, but would never be performed by a browser user.


    So what does it actually mean?

    Here are a few examples:

    1. Siebel-Web protocol – first web_reg_save_param… step that uses Siebel correlation library takes time on DLL  invocation and this time reported as “wasted”.
    2. The similar case exists with openSSL components (additional 1 second before handshake).
    3. Time spent of text search (web_reg_find) also reported as “wasted”.

    So basically it is the time that was wasted in LR code which would not be wasted by a real user.

ss2014 on ‎06-24-2014 01:23 AM

Can anyone help me with REST API scripting in Vugen. I have a XSD for the REST API service. PlEASE LET ME KNWO HOW TO GO ABOUT IT

rogerckk on ‎11-26-2014 01:33 AM



I'm trying to scripts using Loadrunner VuGen for SAP performance testing.


Does anyone know how to scripts the VuGen via SAP in order to read the background Job status (SM37) by clicking refresh until the Job Status from "Active" change to "Finished".(Using loop) Once the status it finished, then it will proceed with the next action.


Thank you


Best regards,


on ‎01-21-2015 08:26 AM

Regarding the OP, when reporting response time metrics, is the wasted time removed from the actual response time or included in the duration?

munna73 on ‎02-25-2015 06:28 PM

HTTP 302 Errors


I ran a performance test in Summary report I see HTTP 302 errors, I ma trying to locate the source of this errros. I check output logs with extended logs enabled byut I can not find the source of this error.


Did any body ever get HTTP 302 errors in HTTP Responses Summary in Summmary Report generated after completion of the Performace Test run.

I have noticved one thing if the script has run for 350 iterations I am seeing 350 HTTP 302 errors.


Any advise.

Dondaya on ‎03-18-2015 12:20 AM

Hi All,


I Need help in sloving Loadrunner Scripting Problem.

I am recording SAP S&OP Application (i.e., MS Excel sheet) logon, opening template and clicking on simulate button and logoff.

Using Web(HTTP/HTML) protocol (LR12).


All other transaction is passing Except : click on Simulate Button.


Error -26631: HTTP Status-Code=400 (Bad Request) for "http://***************/sap/sop/sopfnd/services/addin/excel/query/SOP/EMCPA?method=send"


I have added all the required Headers for the above request. but still same error.

all i can see in difference between Recoding and Reply for the request are:


in raw data of Replay log same not present in recording log:

1> User-Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows; Trident/5.0; en)


in respones body difference is:


2> recording Log something goes like this : {
    "extendedData": [
                "name": "SOPFilter",
                "value": "{"name":null,"id":0,"conditions":[{"dimensionId":"******FAMILYDESC","operatorCode":"EQ","values":["DATADOMAIN"]},{"dimensionId":"*****SOURCEGROUP","operatorCode":"EQ","values":["EVAL","Sale"]},{"dimensionId":"*****USAGETYPE","operatorCode":"EQ","values":["SOLUTION"]},{"dimensionId":"*****LLMODELGROUP","operatorCode":"EQ","values":["ANCHOR


but in replay log :

[{"causeMessage":null,"code":"UNEXPECTED_ERROR","description":"Your session has timed out due to inactivity. Any unsaved changes have been lost. To re-establish the session, log off and then log back on.","message":"Your session has timed out due to inactivity. Any unsaved changes have been lost. To re-establish the session, log off and then log back on.","localizedCauseMessage":null,"localizedMessage":null,"log_id":"d6afb6f5-f994-4182-b14b-4ca68dc075ff","severity":"INFO","variables":[]}]


Please if any of you have solution , Let me know

Thank you in Advance


satishkommu on ‎03-31-2015 10:59 PM

Hi Everyone,


I have Recorded Script in VUGen 12.02 (Community Edition) for an CRM Application (Standalone) using HTTP/HTML Protocol.


 Technologies Used in Application (CRM) : Dot Net Framework, CRM Application & Java Application


I have Correleated for an Dynamic Value (URN: UUID) using web_reg_save_param, iam able to capture it but when i replaced the dynamic variable in the script, iam getting below error message.


Left and Right Boundries in the script


LB = urn:uuid:",



web_reg_save_param("Corr_UUID","LB= urn:uuid:","RB=<","ORD=1",LAST);


While Replaying the script iam getting the below error messages


Action.c(89): Warning: The String "Corr_UUID" with parameter delimeters is not a parameter

Action.c(89): Notify: Saving Parameter "Corr_UUID={Corr_UUID}"


Please help me in resolving the issue.


Thanks & Regards




on ‎06-03-2015 10:54 AM

VuGen (12.00)  is in some strange State, even after quitting and restarting. 


This behavior started as a result of Tools / Compare???


Have two tabs(elipses?) in the script area "HP.VuGenC.Global.Action" and "Action()" which I cannot remove.

Status at bottom is "Compiling..." after trying to run a script which results in "An error has occurred"

then everything is greyed-out except menu bar.  Right clicking in Solution Explorer similar, cannot "Save Script" or "Remove Script" due to grey-out



suchhanda on ‎06-26-2015 05:44 AM

Can we record games/video in loadrunner ??  The application uses MP3 request.

aniketh on ‎07-03-2015 03:58 AM

In HP ALM Performance Center 11.52 am getting the following error intermittently during load testing Rest APIs. However on vugen the script works perfectly fine.


Continuing after Error -26563: Non-empty response body is invalid with HTTP Status Code 204 (No Content) for ""      [MsgId: MERR-26563]


Can anyone assist me with this error ?

Any solution to this error ?



dhananjay1 on ‎08-19-2015 02:03 AM

 Hi ,


I want ot record the script in Google Chrome using Load Runner 11.00 ?Can we do need to extra setting for that.please assist to sort out this issue.