LoadRunner Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

GENERAL_MSG_CAT_SSL_ERROR: Connection failed to host during replay of the script

SOLVED
Go to Solution
Valued Contributor

GENERAL_MSG_CAT_SSL_ERROR: Connection failed to host during replay of the script

Hi,

I am using LR 11.52. During recording of the script, application shows a certificate error and I proceed with that and able to record the script. 

However during reply when script trying to establish SSL connecting, getting the above error.

 

Can anybody suggest what could be the issue and how to fix it?

 

Thanks

Thanks
Deb
8 REPLIES
HPE Expert

Re: GENERAL_MSG_CAT_SSL_ERROR: Connection failed to host during replay of the script

Please check this KB article:

http://support.openview.hp.com/selfsolve/document/KM00518042

 

Regards,

Mario M.

HP LR/PC Support

If you are customer you can try posting on our internal forums for more personalized support.

LoadRunner:
http://h30499.www3.hp.com/t5/LoadRunner-Support-Customer/bd-p/loadrunner-support-customer-forum

Performance Center:
http://h30499.www3.hp.com/t5/Performance-Center-Support/bd-p/performance-center-support-customer

How to:
http://www.youtube.com/watch?v=4ChlysWupWM

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Valued Contributor

Re: GENERAL_MSG_CAT_SSL_ERROR: Connection failed to host during replay of the script

Hi Mario,

Thanks for sending the information but it didn't work out. Any other suggestion?
Thanks
Deb
Highlighted
Valued Contributor

Re: GENERAL_MSG_CAT_SSL_ERROR: Connection failed to host during replay of the script

Hi All,

 

Figured what is the issue. Here is the background 

 

Our application host on MS Azure and the machine I am using is inside our org intranet behind the firewall. So direct connection was not possible. So I had to use proxy server. 

 

By manually checking thru firefox connection log I can see for SSL connection, application is using SSL version TLSv1, however while running the script from LoadRunner, by default it is sending SSL version SSL2/3. This is the root cause causing the problem. So below line did the trick by forcing LR to run SSL version TLS.

 

web_set_sockets_option("SSL_VERSION","TLS);
 
This resolved the issue. 
njoy .. 

 

Thanks
Deb
Visitor

Re: GENERAL_MSG_CAT_SSL_ERROR: Connection failed to host during replay of the script

Hi Deb,

 

    Your solution was helpful. Can you let me know how you found that while running the script it was taking SSL2/3 instead of TLSv1?

 

Regards

VK. Reju

Occasional Advisor

Re: GENERAL_MSG_CAT_SSL_ERROR: Connection failed to host during replay of the script

There is a syntax error in here. The update is below.  The last quote was missing after TLS.

 

web_set_sockets_option("SSL_VERSION","TLS";

 

 

Visitor

Re: GENERAL_MSG_CAT_SSL_ERROR: Connection failed to host during replay of the script

1) Correct one: web_set_sockets_option("SSL_VERSION","TLS");

 

2) missing   )    -->  web_set_sockets_option("SSL_VERSION","TLS";

 

3) missing    "    -->  web_set_sockets_option("SSL_VERSION","TLS);

 

 

 

Moshe

Re: GENERAL_MSG_CAT_SSL_ERROR: Connection failed to host during replay of the script

hi 

 

even we have the same issue, can some body help us by telling where we have edit this lines in that script or its an command we have to run.

 

web_set_sockets_option("SSL_VERSION","TLS";

 

kindly assist us we are new to this loadrunner.

 

regards

roopesh

Visitor

Re: GENERAL_MSG_CAT_SSL_ERROR: Connection failed to host during replay of the script

Roopesh_Shetty,

 

   It needs be put as the 1st step in Vuser_init() or Action().

 

   The correct function call is web_set_sockets_option("SSL_VERSION","TLS");