LoadRunner Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Web Application SAML login - Script recording/reply

Occasional Contributor

Web Application SAML login - Script recording/reply

Trying to test a Web application which uses SAML SSO login. I can see a parameter SAMlart getting passed as part of one of the login request hits. But can’t find the value anywhere in the generation log. 

 

From basic gogling I've found that these SAML values are generated dynamically. But how can I correlate them in my script? Do I need to use Web+Web Service and go for the SAML options avail in Web Service?

 

Any suggestions would be very helpful!!

5 REPLIES
Highlighted
Occasional Contributor

Re: Web Application SAML login - Script recording/reply

To add some details, I get a hit similar to below for the login step.. 

 

web_url("app",
"URL=appurl/saml/SSO/alias/wms?SAMLart=AAQAAHE3kUAJcExudbryrN79alnmmAgyQAkr3lXnh0OkuBFenLCYK3pN7pc%3D",

 

though we pass a credential at the log in step, its not recorded. I assume its converted to the SAMLart for authentication. how can I handle this?

Occasional Advisor

Re: Web Application SAML login - Script recording/reply

Same issue facing here, could anyone solved/overcome these kind of issues?

 

Regular Advisor

Re: Web Application SAML login - Script recording/reply

If this token was generated by a client (code executed in a browser), you need to:

- review this code

- recreate this function in LR script

Frequent Advisor

Re: Web Application SAML login - Script recording/reply

If the SMALart value is recieved in previus responses, you should correlate it (using web_reg_save_param_* API). Otherwise, if generated by client you should generate it yourself (or send the same value).

Thanks,

Yoav

Occasional Advisor

Re: Web Application SAML login - Script recording/reply

Hello