LoadRunner Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

in RTE protocol exit is not happening giving timeout error

Frequent Advisor

in RTE protocol exit is not happening giving timeout error

through script I wrote a code :

 

below I am unable to exit from putty gives 90 timeout error, cursor blink till "sometext>" I expect exit should type here from below bottom lines

 

TE_type("g.ack<kReturn>");
    TE_wait_text("sometext>", 90,1,yStartPos+1,80,600,&xStartPos,&yStartPos);
    TE_wait_sync();
    lr_output_message("=================%d",yStartPos);

    TE_get_text_line(1,yStartPos-1,-1,text);
    //lr_output_message("=========##===%s",text);

        while(row<yStartPos)   //row=1
            {
                TE_get_text_line(1,row,-1,text);
                lr_output_message("##########%s",text);
                row++;
            }


    TE_type("exit<kReturn>");  //exit is not typing after exiting loop
    TE_type("exit<kReturn>");

prod support
telecom

Smile tomorrow will be worse !!!
1 REPLY
Highlighted
Frequent Advisor

Re: in RTE protocol exit is not happening giving timeout error

this issue is resolved
int i=0,xStartPos=0,yStartPos=0,xEndPos=0,yEndPos=0,lineNo=0,xPos=0,yPos=0,row=1;
char gettext[200];
TE_type("cd path\<kReturn>");
TE_wait_text("patterntwait>", 90,1,yStartPos+1,80,200,&xStartPos,&yStartPos);
TE_wait_sync();
TE_type("g.ack<kReturn>");
TE_wait_text("patterntwait>", 90,1,yStartPos+1,80,200,&xEndPos,&yEndPos);
for(lineNo=yStartPos+1;lineNo<yEndPos;lineNo++)
{
TE_get_text_line(1,lineNo,-1,gettext);
lr_output_message("%s",gettext);
}
prod support
telecom

Smile tomorrow will be worse !!!