LoadRunner Support Forum
Showing results for 
Search instead for 
Do you mean 

Issue with running Ajax truclient scripts in PC 11.52 version

Frequent Visitor

Issue with running Ajax truclient scripts in PC 11.52 version

 

Hi All,

 

 Need your expert advice on the situation that I am facing while doing a load test execution with Ajax Truclient (IE9) scripts using PC 11.52 version. I am having 3 scripts (A, B,C) in total. But during execution of these scripts we see the below random behaviour.

 

Environment details are as below.

 

Machine 1 -

Performance Center  Version 11.52 Patch 1

Controller  - Ver 11.52.00

Hardware Config- 1 core CPU 2.78 Ghz and 8 GB Memory

 

Machine 2 -

Load Generator Ver  11.52.00

Hardware Config- 1 core CPU 2.78 Ghz and 8 GB Memory

 

PS the attacment for more details on the version

 

 

All there scripts are tested for multiple iterations in VuGen and its sussessfully running. Also these script are individually loaded in to LG and then we have run for 5 users each scripts successfully.

 

But when we run these scripts in contoller (with the contoller acting as LG) it struck in the init section and is getting timed out. In some cases its is getting passed init section and is further proceeding. If the users are more than 5 from the 6 th users its script is in init.The behaviour of the scripts is random when we increase the user count more than 5 users.  This is the same behaviour that we notice while running from the LG also.(During the test duration we manually checked the application and the same is working perfectly ok)

 

Please suggest what shoud be the possible reason of this random behaviour during exeuction of these scripts. Any leads to solve the same is much appreciated.

5 REPLIES
HPE Expert

Re: Issue with running Ajax truclient scripts in PC 11.52 version

Can you share the script please?

Guy Rosenthal
Network Virtualization PM
Visitor

Re: Issue with running Ajax truclient scripts in PC 11.52 version

Is this Issue resolved? I also have similar problem where the ajax truclient script works in vugen but with a load of even 4 users it is failing? It gets stuck almost at the begining of the script.

HPE Expert

Re: Issue with running Ajax truclient scripts in PC 11.52 version

Hi,

The original thread stopped so no resolution (the one who post it didnt respond).

 

It might be that your problem is unrelated.

Can you please indicate your version? is it TruClient Firefox or IE?

Did you make sure that the proxy seetings on the LG (Run Time Settings) are configured correctly? 

Guy Rosenthal
Network Virtualization PM
Visitor

Re: Issue with running Ajax truclient scripts in PC 11.52 version

Windows Server 2003

 

LR Version 11.04.0.0

 

Ajax Truclient FireFox

 

The following is my issue. My script works fine in Vugen and in controller with one user. But When I put load of even 2, the second user never gets even to the first page. 

 

Either it is a security pop issue(it was recorded after adding to the security websites and pop ups were enabled.

 

Pls let me know if you can think of a solution.

 

Highlighted
Valued Contributor

Re: Issue with running Ajax truclient scripts in PC 11.52 version

Try two things.

1. Disable IP spoofing if enabled  and run the script without IP spoofing

2. Upload the script to PC from VuGen with runtime only files and not all files

 

and see that if it helps.

 

Thanks!