LoadRunner Support Forum
Showing results for 
Search instead for 
Do you mean 

Unresolved symbol : web_reg_save_param_regexp

Highlighted
Frequent Advisor

Unresolved symbol : web_reg_save_param_regexp

Hi Experts,

 

I am using VuGEN 11.03 and I have got a script from my colleague which has web_reg_save_param_regexp" function used into it. Whiile running on my VuGEN, I am facing the below mentioned issue:

 

Error: C interpreter run time error: Action.c (102):  Error -- Unresolved symbol : web_reg_save_param_regexp

 

It seems this function is not available on my current version of VuGEN 11.03. I tried to find this function in VuGEN helpfile but could not found it.

 

1) Please suggest Is there any kind of patch available or any ways to make this function available in my VuGEN?

2) Also, if I directly run this script on BPM 9.13/9.03, will this function work on BPM(I am assuming here that BPMs may have libraries for this function reference).

 

 

Thanks & Best Regards,

Mayank

5 REPLIES
HPE Expert

Re: Unresolved symbol : web_reg_save_param_regexp

Hi Mayank,

 

If the script was recorded in a newer version of LoadRunner it could be causing the problem.

 

LR 11.03 supports web_reg_save_param_regexp and it is available in the function reference starting from LoadRunner 11.01. KM1088844

 

As per the following document: C interpreter run time error when using web_global_verification & web_reg_save_param_regexp you can check if the script contains web_global_verification before web_global_verification.

 

However if the function is not available in the function reference, I guess that there could be an issue with your installation of LR or VuGen. Please review the following KM: What patches are available for LoadRunner 11 and the order they should be installed?

 

You will see that you should have Critical patch and LR patch 3 installed on top of LR 11.00.

Both BPM 9.13/9.03  support VuGen 11.03 so you can try to reply the script in BPM in case it was recorded and replays successfully in LoadRunner 11.03.

 

You can find BPM – VuGen Compatibility matrix in the following post http://h30499.www3.hp.com/t5/LoadRunner-Support-Customer/LR-Support-Tip-BPM-9-23-now-supports-VuGen-...

 

Kind regards,

HPE Support
If you haven’t tried it yet, come and join us in our entitled forums at Support Customer Forums

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution and give Kudos to the author for their assistance.
Frequent Advisor

Re: Unresolved symbol : web_reg_save_param_regexp

[ Edited ]

vmanolova wrote:

 

LR 11.03 supports web_reg_save_param_regexp and it is available in the function reference starting from LoadRunner 11.01.


How do you know that?

 

How do you get those information? By hardcore trial-and-error?

============================================
HPE Expert

Re: Unresolved symbol : web_reg_save_param_regexp

Hi,

 

This information is available in the knowledge document:

https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM1088844

Which version of LoadRunner are you working with and what is the exact error message you are receiving?

 

Please also note that LoadRunner 11.0x commited support will end on Feb 28 2015 (please check the following link:  http://support.openview.hp.com/encore/products_f-n.jsp ) and it is recommended to upgrade to a new version.

 

Kind regards,

Vesela

 

HPE Support
If you haven’t tried it yet, come and join us in our entitled forums at Support Customer Forums

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution and give Kudos to the author for their assistance.
Frequent Advisor

Re: Unresolved symbol : web_reg_save_param_regexp


vmanolova wrote:

This information is available in the knowledge document:

https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM1088844


The page you linked shows an empty "heading" page:

 

Untitled.png

 

How do we read the information located in KM1088844?

============================================
HPE Expert

Re: Unresolved symbol : web_reg_save_param_regexp

Hi, 

 

The content of the knowledge document is visible at the moment. The information it conatins about web_reg_save_param_regexp function is "Added function reference for the web_reg_save_param_regexp function".

 

Still if you face an issue with this function, please let us know which is the version and patch level of LoadRunner you are using and the syntax of the problematic function.

 

Thanks and kind regards, 

Vesela 

HPE Support
If you haven’t tried it yet, come and join us in our entitled forums at Support Customer Forums

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution and give Kudos to the author for their assistance.