LoadRunner Support Forum
Showing results for 
Search instead for 
Do you mean 

"Set Cookie:" not captured in alternate iterations

Highlighted
Occasional Advisor

"Set Cookie:" not captured in alternate iterations

Hi,

 

My script has Vuser_init, Action & Vuser_end.

 

This is web based application. I have corelated using automated corelation. The issue is when I replay the script (1 itreation), it is throwing error message immediately after web_reg_save_param function stating ensure boundaries exist. When I play for second time, the script runs fine.

 

I set the log mode to Advance trace and find that when the script runs successfully, the following is captured:

 

Set-Cookie: MPORTCOOKIE=SESSION_TIMEOUT%3D1800%3BCHANGE_RR_CODE_URL

 

I am not seeing this when the script is failing. As a pattern it follows:

 

Replay 1 - Failed

Replay 2 - Pass

Replay 3 - Failed

Replay 4 - Pass

.

.

.

 

 

What is that I am missing?

 

Please help.

 

Thanks.

 

Mouli.

3 REPLIES
Occasional Advisor

Re: "Set Cookie:" not captured in alternate iterations

At the bottom of the log, I see this message:

 

"Closed connection to [Server] after completing 7 requests "

"Closed connection to [Server] after completing 3 requests "

"Closed connection to [Server] after completing 1 requests "

 

All pointing to same URL.

 

Incase this helps?

Occasional Advisor

Re: "Set Cookie:" not captured in alternate iterations

I guess you should remove "

Set-Cookie: MPORTCOOKIE=SESSION_TIMEOUT%3D1800%3BCHANGE_RR_CODE_URL" and all the cookie lines in your scripts as it changed and the original value recorded will not work for mutiple iteration.

HPE Expert

Re: "Set Cookie:" not captured in alternate iterations

Hello
In the past I´ve seen this same behavior caused by application load balancers, you may want to check on that.

regards