MSM Series
Showing results for 
Search instead for 
Do you mean 

FW NAT option greyed out

Occasional Advisor

FW NAT option greyed out

[ Edited ]

Ever since upgrading to FW on our MSM765zl controllers the NAT option on the interface context is greyed out.

Now this is the ultimate show stopper and - sorry for the profanity - a super pain in the ass.


Check the attachment for a screenshot.


I can download the configuration, change the 

nat = 

part in the 


 context and re-upload the file, but this if course causes a controller reboot.


So ... any ideas on how to get that radio button enabled again?


The release notes for state that


If the MSM7xx Controller is configured with the NAT feature enabled (default setting) and with the
Extend VSC egress subnet to VSC ingress subnet feature enabled (disabled by default), the v6.2.0.0
software will disable the NAT feature. It is recommended that you review your existing settings and
disable one of these features before upgrading to v6.2.0.0.

 But I'm not using the DHCP relay agent, so I can't even uncheck the "Extend VSC egress subnet to VSC ingress subnet" setting, which is greyed out, too, by the way.



The NAT option can be set via the CLI (VLAN interface context) though.


Just in case someone else encounters this problem, on the CLI syntax to enable NATing on a L3 interface on the internet (what a stupid name) L2 interface is:


        interface ethernet port-2
            interface vlan "vlan name"
                ip nat