Network Management / (OpenView-NNM) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

High CPU util on router

Occasional Advisor

High CPU util on router

One of our NMS is running NNM5.1 on Solaris 2.6 platform. Whenever openview is
running, the CPU utilization on one of the hub routers goes up to 90% plus
every two minutes. A 'show proc cpu' on the router showed that all the activity
was due to IP SNMP polling, so OV was definitely the problem.
This happens to only one of the hub routers, which is not even the default
router for the NNM system.
Any help to debug the prob would be appreciated

Madhu
3 REPLIES
Highlighted
Occasional Advisor

Re: High CPU util on router

HI !

I had a same kind of problem quite a long time.
You did not mention the made of router, if it's Cisco you have same problem.

There is a NNM patch PSOV_02649 that corrects part of the problem (when router
sends a Link Up/ Link down traps).
The other part is a big routing table or NetToMedia tables (static route
tables).
For some reason reading these tables via SNMP consumes a of CPU seconds !!
I think this is also Cisco IOS problem.

Reg

Otto :)
Occasional Advisor

Re: High CPU util on router

HI !

I had a same kind of problem quite a long time.
You did not mention the made of router, if it's Cisco you have same problem.

There is a NNM patch PSOV_02649 that corrects part of the problem (when router
sends a Link Up/ Link down traps).
The other part is a big routing table or NetToMedia tables (static route
tables).
For some reason reading these tables via SNMP consumes a of CPU seconds !!
I think this is also Cisco IOS problem.

Reg

Otto :)
Occasional Advisor

Re: High CPU util on router

Hi Otto,

Thanks for the help. I shall try the patch, but you did say it solves only part
of the problem. The router is Cisco and the IOS version is 12, so it could not
really be a IOS problem could it, cause it is a recent version I think?
How did u debug the prob fully?

Madhu