Network Management / (OpenView-NNM) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

NNMi 9.10 failed to start with FQDN via IE8

Highlighted
Frequent Advisor

NNMi 9.10 failed to start with FQDN via IE8

[ Edited ]

Hi Gurus,

 

I am not able to start NNMi using hostname. It seems that I can use via IP address.

I attempted to hardcode the hostname and ip address but, still I am not able to access it.

 

Any ideas?

 

Thank you.

14 REPLIES
Honored Contributor

Re: NNMi 9.10 failed to start with hostname via IE8

What error messages do you see when you try and access NNMi using a hostname?

If you open a command window on your system, and run "ping <hostname of server>", does it work? What IP address does it ping?

I don't know what your network environment looks like, but I would also be checking your proxy configuration.
Frequent Advisor

Re: NNMi 9.10 failed to start with hostname via IE8

Hi North,

 

I have attached some screen capture of the environment.

Honored Contributor

Re: NNMi 9.10 failed to start with hostname via IE8

There are different IPv6 addresses in the System Information page, and in DNS. Which one is correct? Is your browser trying to connect to the wrong IPv6 address?
Frequent Advisor

Re: NNMi 9.10 failed to start with hostname via IE8

I am connecting to IPv4. Thank you for pointing out on the IPv6 also, I might have to look int that why they are different. but for now, IPv4 should be the correct one.

Honored Contributor

Re: NNMi 9.10 failed to start with hostname via IE8

I'm not sure what the default behaviour is with IE8, but if your client has an IPv6 address, and DNS is returning an IPv6 address, then it will probably be trying to connect via IPv6. Probably IPv4 too.

What error messages is your browser giving you? Turn off "friendly error messages", or use a different browser, as the default error page on IE is meaningless.

When you try to connect using the FQDN, is your client machine definitely sending traffic to the right system? (Verify with wireshark)

Could you also explain what you did when you "hardcoded the name and IP address" ?

Is this from a remote system, or are you running IE on the NNMi server?
Frequent Advisor

Re: NNMi 9.10 failed to start with hostname via IE8

What error messages is your browser giving you? Turn off "friendly error messages", or use a different browser, as the default error page on IE is meaningless.

 

SY>> I turned off "friendly error" and its the same error page.



When you try to connect using the FQDN, is your client machine definitely sending traffic to the right system? (Verify with wireshark)

 

SY>> Nothing shows up. However I am abl eto log in either hostname and IP. But when i log in as hostname it shows the full fqdn...somethings is strange

 


Could you also explain what you did when you "hardcoded the name and IP address" ?

 

SY>> hardcode in windows/system32/etc/host

Is this from a remote system, or are you running IE on the NNMi server?

 

SY>> I am running IE on NNMi server. No other IE in the system.

Honored Contributor

Re: NNMi 9.10 failed to start with hostname via IE8

Without getting a meaningful error message from IE, it's very difficult to know what the problem is. We need to find out if it can't resolve that name, or if it is getting a connection refused (because it's going to the wrong IP).

 

What proxy settings do you have on IE? One possibility is that you have a proxy defined, and IE can't reach the proxy. The standard setting is to bypass the proxy for local sites. When you use the shortname, it bypasses the proxy. But when you use the full name, it may be trying to use the proxy.

 

Can you open a command line, and run "ping <FQDN>" - I want to see which IP it tries to ping.

Frequent Advisor

Re: NNMi 9.10 failed to start with hostname via IE8

Attached is the screen capture.

Honored Contributor

Re: NNMi 9.10 failed to start with hostname via IE8

It's possible that IE is trying to connect to the IPv6 address, rather than the v4 address. NNMi is probably not listening on the v6 interface, but only the v4 address.

What about your proxy settings?
Frequent Advisor

Re: NNMi 9.10 failed to start with hostname via IE8

No proxy on this environment. If i ping -4 it will show the correct ipv4. ipv6 will always take presendence.

Honored Contributor

Re: NNMi 9.10 failed to start with hostname via IE8

You might need to investigate IE8 behaviour with v6 addresses.

Or just use the shortname, or only access NNMi via a remote browser?
Frequent Advisor

Re: NNMi 9.10 failed to start with hostname via IE8

Thanks for you help. Looks like I will logged a case with HP to find out why. This only recetly happen when I was generating alot of report using ispi it crashed that since that day I was not able to get it to work using the FQDN.

 

 

Honored Contributor

Re: NNMi 9.10 failed to start with hostname via IE8

Might be your best course. Sorry we couldn't get to the bottom of it!
Frequent Advisor

Re: NNMi 9.10 failed to start with hostname via IE8

You did great, thanks dude.