Network Management / (OpenView-NNM) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

NPS 9.20 fails because of missing libjpeg.i686 & libjpeg.x86_64 libraries

SOLVED
Go to Solution
Highlighted
Frequent Advisor

NPS 9.20 fails because of missing libjpeg.i686 & libjpeg.x86_64 libraries

Hi all,

NPS 9.20 fresh installation on a dedicated server (RHEL 6.5) fails because of missing libjpeg.i686 & libjpeg.x86_64 libraries as stated in /var/tmp/PerfSPI_AppCheckReqdLibs.sh.txt (see below).
These libraries have been obsoleted in RHEL 6.x by libjpeg-turbo.i686 & libjpeg-turbo.x86_64 accordingly.
What can be done in order to have a successful installation?

 

::::: PerfSPI_AppCheckReqdLibs.sh.txt START :::::
=========================
Wed Jul 30 11:53:16 EEST 2014
OS: Linux
-------------------------
libstdc++-4.4.7-4.el6.i686
compat-libstdc++-296-2.96-144.el6.i686
compat-libstdc++-33-3.2.3-69.el6.i686
compat-libstdc++-33-3.2.3-69.el6.x86_64
package libjpeg.i686 is not installed
INFO: Required library not installed: libjpeg.i686
package libjpeg.x86_64 is not installed
INFO: Required library not installed: libjpeg.x86_64
libpng-1.2.49-1.el6_2.i686
libpng-1.2.49-1.el6_2.x86_64
libXp-1.0.0-15.1.el6.i686
libXp-1.0.0-15.1.el6.x86_64
ncurses-5.7-3.20090208.el6.x86_64
openmotif22-2.2.3-19.el6.i686
openmotif22-2.2.3-19.el6.x86_64
tcsh-6.17-24.el6.x86_64
unixODBC-2.2.14-12.el6_3.i686
unixODBC-2.2.14-12.el6_3.x86_64
unixODBC-devel-2.2.14-12.el6_3.i686
unixODBC-devel-2.2.14-12.el6_3.x86_64
libXtst-1.2.1-2.el6.i686
INFO: Run the following command, or otherwise install the identified missing libraries
INFO: #yum install libjpeg.i686 libjpeg.x86_64
ERROR: Please install the required libraries, and then re-run the installer (Logfile /var/tmp/PerfSPI_AppCheckReqdLibs.sh.txt)
::::: PerfSPI_AppCheckReqdLibs.sh.txt END :::::

 

Thank you in advance,


Costas

 

2 REPLIES
Trusted Contributor

Re: NPS 9.20 fails because of missing libjpeg.i686 & libjpeg.x86_64 libraries

Hello,

This is documented at:

Title: HP NNMi iSPI Performance for Metrics v9.20: Installation pre-requisite check fails as required library on linux has been obsoleted (libjpeg versus libjpegturbo)

http://support.openview.hp.com/selfsolve/document/KM00822676

 

The link should help.

Mohit Sharma,
HP Software Support

The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of HP.

If you find this or any post resolves your issue, please be sure to mark it as an accepted solution.
Frequent Advisor

Re: NPS 9.20 fails because of missing libjpeg.i686 & libjpeg.x86_64 libraries

Thank you Mohit,

 

Best Regards,

 

Costas