Network Management / (OpenView-NNM) Support and News Forum
Showing results for 
Search instead for 
Do you mean 

Objects are marked as REMOVED in Database of NNM 6.1

Occasional Visitor

Objects are marked as REMOVED in Database of NNM 6.1

I experienced a problem on Topology database in NNM6.1 for solaris.

In my environment, I have two collection stations reporting to one management
station. They are all NNM 6.1. On the management station many objects are
marked as REMOVED in database, I can do nothing on it. After I do ovtopofix -a,
the objects are not marked as REMOVED any more. Everything seems fine. But
after a few minutes, they are marked again.

I checked two collection stations, they are OK.

BTW, whatever netmon is running or not, that problem is the same.

My environment:
Solaris 2.6
Super Advisor

Re: Objects are marked as REMOVED in Database of NNM 6.1

When a node is deleted by netmon, ovtopmd marks the node "REMOVED:",
unsets the IP and TopM specific fields from ovwdb, and generates a node deleted
event. The node deleted event is forwarded by pmd to ipmap. ipmap will then
query ovtopmd for information regarding the delete and will remove the node
from IP map submaps.

When the last symbol representing an object is deleted, an
ovwConfirmDeleteObjects callback is generated by OVw to applications who have
registered for it.

Perhaps you need to run ovw -mapcount -ruD, then ovtopofix -W to repair the
database and reset the map count:

1. Everyone out of the maps. Run:
ps -ef|grep ovw # kill -9 leftover process id's still running,
except ovlmd
2. ovtopofix -Wv
3. ovstart
4. ovstop netmon
5. ovw -mapcount -ruvD
6. ovtopofix -a
7. ovstart netmon