Network Management / (OpenView-NNM) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Recommended way to troubleshoot/debug <no smnp> device for Cisco3020 switches?

Frequent Advisor

Recommended way to troubleshoot/debug <no smnp> device for Cisco3020 switches?

I have the same cisco configuration on 18 devices. 16 show up as <no snmp>. The other 2 are fine.

How can I generate a debug file (from the nnmi side) to isolate the problem?

NNMi 9 patch 2 RHEL 5.5

3 REPLIES
Honored Contributor Honored Contributor

Re: Recommended way to troubleshoot/debug <no smnp> device for Cisco3020 switches?

Hi,

 

We can rule out an IP communication problem. What you must do first of all, check your NNMi communication settings. Select on your NNMi console: Inventory > Nodes > tickmark one of your <no snmp> nodes > on menu Actions > Communication Settings.  In the ouput window check what source (the configuration defined at NNMi Communication Settings) is being used to resolv the community string(s) to be used during discovery, found at the row Communities where you also can find the community string(s) being used.

 

If these settings are correct check the SNMP communication on the command line with 'nnmsnmpwalk.ovpl -c <community-string> <node> system.sysName

 

Success

 

DJ

Frequent Advisor

Re: Recommended way to troubleshoot/debug <no smnp> device for Cisco3020 switches?

Actually I found out that the Cisco 3020's associated with the blade enclosures are not supported by nnmi 9.

We've filed a request to the labs to have them added.

Honored Contributor Honored Contributor

Re: Recommended way to troubleshoot/debug <no smnp> device for Cisco3020 switches?

Hi, I can't believe that's the core of your problem. NNMi should at least add your device as SNMP manageable with <No Device Profile>. You can add your own device profiles temporarily. Regards,

 

DJ