Network Management / (OpenView-NNM) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Report Menu stopped working? NNMi 9.1

Advisor

Report Menu stopped working? NNMi 9.1

Hi All,

 

   We had an outage on June 3rd across a link, and I was able to collect traffic stats and node stats using the Reporting menu.

 

Three days later we had a failure on the same link, but for whatever reason, it wouldn't display any data from that night. I would select the stats  I want to see, the time frame, and the interface group as per usual, but nothing would come up... It didn't seem to have any data for any device at that time.

 

The server didn't fail during the outage, so I'm not sure what happened. Any thoughts? I'm not even sure where to begin troubleshooting this.

 

Actually, now that I look at it again, it seemed to have stopped collecting Data as of June 5th.

 

Is there anything that could cause that? Is there a way I can re-start the service, or process that captures the data?

 

Thanks.

8 REPLIES
Honored Contributor

Re: Report Menu stopped working? NNMi 9.1

You shouldn't have to do anything after a link failure. Sometimes reporting data collection can fail for other reasons though.

 

Take a look at /var/opt/OV/nnm/shared/perfSpi/datafiles/metric/final  (or equivalent dir on Windows) - do you see a large number of files there? If you do, sometimes you need to restart the iSPI processes - stopALL.ovpl, startALL.ovpl.

 

iSPI will then go through and process the files, and you'll be able to run reports. Might take a while. You'll know it's finished consuming the files when the number of files in that directory shrinks to zero, or close to it.

Advisor

Re: Report Menu stopped working? NNMi 9.1

I will take a look into that. Thanks for the info!

Advisor

Re: Report Menu stopped working? NNMi 9.1

Ok, I checked the Windows equivilant of that directory, and there were zero files in it.

<Drive>:\HP\HP BTO Software\PERFSPIDATA\NNMPerformanceSPI\logs\PerfSPI_Diagnostics\metric\final

SHould I still attempt to stop and start the process??

 

Or is there anygthing else I should try??

HPE Expert

Re: Report Menu stopped working? NNMi 9.1

Hello Comunnity

 

I would suggest to look the following documents for this particular issue.

 

http://support.openview.hp.com/selfsolve/document/KM1202944

 http://support.openview.hp.com/selfsolve/document/KM1300740

 

Please visit our new customer forum if you have a valid SAID  support contract at the following link.



http://h30499.www3.hp.com/t5/Network-Node-Manager-Support/bd-p/network-node-mgr-support-cust-forum#.UaaEupzqr7M



HP Support

The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of HP

If you find this or any post resolves your issue, please be sure to mark it as an accepted solution,If you are satisfied with anyone’s response please remember to give them a KUDOS and show your appreciation.

Respected Contributor

Re: Report Menu stopped working? NNMi 9.1

Hi,

 

       Check

 

1. checkConfig.ovpl    - Validation should be OK.

2. dbsize.ovpl               - Should not be 100 % Utilized.

3. statusALL.ovpl        - All services should be running.

4. Try Restarting  NFS services if it is running on Cluster once.

Thanks,
Bharath
Honored Contributor Honored Contributor

Re: Report Menu stopped working? NNMi 9.1

Rerun /opt/OV/bin/nnmenableperfspi.ovpl this should recreate the NPS reporting menus.

 

Hope this helps.

Advisor

Re: Report Menu stopped working? NNMi 9.1

Thanks for all the info everyone. Turns out it just needed a reboot to the server. What happened was  I ordered a reboot to a fellow co-worker, and he rebooted the wrong server. That's why it seemed like the software was having some issues, that it wasn't fixed after a reboot... because it was never rebooted.

 

He ended up rebooting the NNMi server instead of the performance monitor server.

 

Thanks.

 

Highlighted
Honored Contributor Honored Contributor

Re: Report Menu stopped working? NNMi 9.1

Thanks for sharing.