Network Management / (OpenView-NNM) Support and News Forum
Showing results for 
Search instead for 
Do you mean 

nnmsnmpwalk for snmpv3 devices

Trusted Contributor

nnmsnmpwalk for snmpv3 devices

Hi,

I am getting below error while running  nnmsnmpwalk.ovpl for snmpv3 deviices,Any suggestion on this.

 

E:\APPS\NNMI\bin>nnmsnmpwalk.ovpl -u system -p nnmi910 -port 161 -v 3 -c abc0g001 -a MD5 -v3u SNMPv3 sensor xxx1-abc-01 sysName
Unable to resolve OID SNX1-IDS-01

Regards,
hp4u
3 REPLIES
HPE Expert

Re: nnmsnmpwalk for snmpv3 devices

Hi,

 

  The command you are using is not quite corret for an snmpv3 device.

 

nnmsnmpwalk.ovpl -u system -p nnmi910 -port 161 -v 3 -c abc0g001 -a MD5 -v3u SNMPv3 sensor xxx1-abc-01 sysName

 

The -c option is not required for a v3 device

if the user is called "SNMPv3 sensor" then you need to quote it.

You need to specify the auth password or not provide the -a if you are going to rely on NNMi to use its internal v3 configuration for the device.  

 

So try

 

nnmsnmpwalk.ovpl -u system -p nnmi910 -port 161 -v 3 -v3u "SNMPv3 sensor" xxx1-abc-01 sysName

or

nnmsnmpwalk.ovpl -u system -p nnmi910 -port 161 -v 3 -v3u "SNMPv3 sensor" -a MD5 -A <authpass> xxx1-abc-01 sysName

 

  All the best

 

Dave Y

HP Support
Viewed the Support tips? Search for "(NNMi) Support Tips" and order by Date to get the list
The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of HP
If you find this or any post resolves your issue, please be sure to mark it as an accepted solution.
Trusted Contributor

Re: nnmsnmpwalk for snmpv3 devices

Hi Dave,

Can you tell me what is "AuthPass" and where i can find it.

Regards,
hp4u
Highlighted
HPE Expert

Re: nnmsnmpwalk for snmpv3 devices

Hi,

 

  the -A and -X options are for the password phrases for the authentication adn privacy protocols respectively.  So you would need to replace the "<authpass>" with the MD5 password phrase that you configured in the device.  Also if the device is configured for privacy you need to add the options   -x <privProtocol> -X <privpass>   as well  - substituting the correct values for the options.

 

  All the best

 

Dave Y

HP Support
Viewed the Support tips? Search for "(NNMi) Support Tips" and order by Date to get the list
The views expressed in my contributions are my own and do not necessarily reflect the views and strategy of HP
If you find this or any post resolves your issue, please be sure to mark it as an accepted solution.