Networking
Showing results for 
Search instead for 
Do you mean 

NFS Error: Running old NFS library, requires new NFS library

SOLVED
Go to Solution
Trusted Contributor

NFS Error: Running old NFS library, requires new NFS library

Hello Everyone,

 

I am trying to share a file but getting error in that. The error are as follows:

Running old NFS library, requires new NFS library.

 

The NFS server OS is HP-UX 11.23 while the client OS is HP-UX 11.31.

Would like to know is it error because of diferent OS version?

 

Anyhelp will be very much appreciated.

1 ACCEPTED SOLUTIONS
Trusted Contributor

Re: NFS Error: Running old NFS library, requires new NFS library

Hi Everyone,

 

Issue resolved.

Summary of activity what i did for others reference.

 If nfs server is HP-UX 11.23 create /etc/exports and make an entry in that.

 

put entry in /etc/dfs/dfstab.

start the services on both client and server.

do: exportfs -v directory path

 

Dennis thanks for your response regarding the exportfs use in 11.23.

 

Thanks everyone for their support.

6 REPLIES
HPE Pro

Re: NFS Error: Running old NFS library, requires new NFS library

Can you please copy/paste the exact command syntax you're issuing and the exact messages you're seeing?

 

Dave

Trusted Contributor

Re: NFS Error: Running old NFS library, requires new NFS library

Hi Dave,

 

Thanks for your reply. Please find the requested details:

 

The command I am using is as follows:

share -F nfs -o rw=/windb/batchlogfiles

error: running old NFS library, requires new NFS library.

 

When I am trying the "/usr/sbin/share" command I am also getting same error on NFS server but not getting that error on client NFS.

 

Syed

Highlighted
Acclaimed Contributor Acclaimed Contributor

Re: NFS Error: Running old NFS library, requires new NFS library

>The command I am using is as follows: share -F nfs -o rw=/windb/batchlogfiles

 

This command is only valid on 11.31 for NFS.

 

>I am also getting same error on NFS server but not getting that error on client NFS.

 

Right.  The correct 11.23 command is exportfs(1m)

 

Trusted Contributor

Re: NFS Error: Running old NFS library, requires new NFS library

Hi Dennis,

 

Thanks for your reply.

When I am using exportfs command getting error:

 

OS= HP-UX 11.23

exportfs -v /windb/batchlogfiles

exportfs error: can't open /etc/exports; No such file or directory.

 

But it has /etc/dfs/dfstab fs, i don't know how it came for 11.23 when it is for 11.31? Making an entry in dfstab didn't workout.

 

Regards

Syed

 

 

 

 

Trusted Contributor

Re: NFS Error: Running old NFS library, requires new NFS library

Hi Everyone,

 

created a file in /etc/exports and put the entry of /windb/batchlogfiles there.

After that did exportfs -v /windb/batchlogfiles

exported /windb/batchlogfiles.

 

Now when trying to mount on client

mount -F nfs IP_Address:/windb/batchlogfiles

geting error

either IP_Address:/windb/batchlgfiles ignored or entry not found in /etc/fstab.

 

Can anyone help what to do to mount it on client?

 

Regards

Syed

Trusted Contributor

Re: NFS Error: Running old NFS library, requires new NFS library

Hi Everyone,

 

Issue resolved.

Summary of activity what i did for others reference.

 If nfs server is HP-UX 11.23 create /etc/exports and make an entry in that.

 

put entry in /etc/dfs/dfstab.

start the services on both client and server.

do: exportfs -v directory path

 

Dennis thanks for your response regarding the exportfs use in 11.23.

 

Thanks everyone for their support.