Showing results for 
Search instead for 
Do you mean 

named[1111]: unexpected RCODE (SERVFAIL) resolving '': X.X.X.X#53

Occasional Advisor

named[1111]: unexpected RCODE (SERVFAIL) resolving '': X.X.X.X#53

[ Edited ]


Please help me to understand.

I have locally DNS running that is configured:

forward only

forwarders (X.X.X.X)



When I see log - I see many entries like that:

named[1234]: unexpected RCODE (SERVFAIL) resolving '': X.X.X.X#53

named[2345]: unexpected RCODE (SERVFAIL) resolving '': X.X.X.X#53


where X.X.X.X is actual forwarder IP

and and is any internet page.


I don't have any IPv6 configuration


listen-on-v6 in section options. 


Why I have this messages then?


Honored Contributor Honored Contributor

Re: named[1111]: unexpected RCODE (SERVFAIL) resolving '': X.X.X.X#53

There is no requirement to actually use the IPv6 protocol to make queries on IPv6 addresses: it is perfectly valid to make queries for IPv6 addresses over an IPv4 connection. The client might have an IPv6-over-IPv4 tunnel or some other IPv6 connection mechanism, which the DNS server does not need to be aware of.


Some client of your local DNS server has made requests for the AAAA records (IPv6 address records) of and Since you have a "forward only" configuration, your DNS server has dutifylly forwarded the queries to X.X.X.X. But X.X.X.X does not seem to like IPv6 at all: it has responded with a SERVFAIL error code.


Many web browsers today are already IPv6-aware, and IPv6 support is slowly increasing in other applications too. Typically, a IPv6-aware application will first ask for a IPv6 address for any DNS name. If the IPv6 query is not successful (or a IPv6 connection attempt fails), the IPv4 address is queried for and used instead.

Occasional Advisor

Re: named[1111]: unexpected RCODE (SERVFAIL) resolving '': X.X.X.X#53

[ Edited ]


Thank you very much for contribution.

I assume then that to disable this resolving for IPv6 it's enaugh to edit

/etc/sysconfig/named and put there


and restart of named.

Do you confirm it?