Patches
Showing results for 
Search instead for 
Do you mean 

Need vim depot with dependencies for 11iv3

SOLVED
Go to Solution
Respected Contributor

Need vim depot with dependencies for 11iv3

[ Edited ]

Hi guys,

Am looking for vim depot download for hp ux 11i v3.

A single depot which will install all dependencies along with vim .

 

 

 

P.S. This thread has been moved from HP-UX > System Administration to HP-UX > patches. - Hp Forum Moderator 

4 REPLIES
Highlighted
Acclaimed Contributor Acclaimed Contributor

Re: Need vim depot with dependencies for 11.31

Have you looked at the Porting Center for vim?  There are 56 runtime dependencies but I'm not sure how make is one of them?  Try depothelper to get them all.

http://hpux.connect.org.uk/hppd/hpux/Editors/vim-7.3/

Honored Contributor Honored Contributor

Re: Need vim depot with dependencies for 11.31

Your best bet is to use the depothelper program that is available from the Porting center.

 

If you want to download vim-7.3, and all of its dependencies, for 11.31 running on PA-RISC then use the following depothelper command:

 

# depothelper -a hppa -c /var/tmp/mydir -n -o 11.31 vim-7.3

 

If you want to download vim-7.3 for 11.31 running on Itanium, then the following command will work:

 

# depothelper -a ia64 -c /var/tmp/mydir -n -o 11.31 vim-7.3

 

The meaning of the options I used:

 

-a <architecture> specifies the machine architecture (ia64|hppa)
-c <cache directory> specifies the cache directory for downloaded files
-n will download the depots but not install them. 
-o <version> specifies the depot OS version to download (11.11|11.23|11.31)

Once the download is complete you can bundle everything into a single depot so you can install everything at once via a single swinstall command.

Respected Contributor

Re: Need vim depot with dependencies for 11.31

Hi Patrick ,

 

Thanks

Will update you after checking the same.

Respected Contributor

Re: Need vim depot with dependencies for 11.31

Hi Patrick ,

 

Even after putting proxy server entry we are not able to download ;

 

root #/tmp >depothelper -p 10.xx.xx.xx:8080 -a ia64 -c /app_dumps/11iv3_vim -o 11.31 vim-7.3
======================================================================================================================================================
Package-version Comment Download Install
======================================================================================================================================================
ia64-11.31 Package list Downloading...

 

 

Not connected.
Not connected.
Not connected.
ia64-11.31 Package list FAILED Not installed
======================================================================================================================================================
ERROR: Can't get list of ia64-11.31 packages from hpux.connect.org.uk - aborted