Patches
Showing results for 
Search instead for 
Do you mean 

hostname not found when installing MirrorDisk/UX

SOLVED
Go to Solution
Frequent Advisor

hostname not found when installing MirrorDisk/UX

[ Edited ]

Hello,

 

I am trying to install MirrorDisk/UX on a fresh install of 11.31. I downloaded "MirrorDisk/UX License for Servers B2491BA 1009.11iv3" from my entitlements, then i did:

- swinstall -s /sd_files/MirrorDisk_UX.tar

 

It allowed me to select the package, but the install fails with:

WARNING: An attempt to get the network host entry for "192.168.100.40" │
│ │ failed. This may result in denial of access to users and │
│ │ agents at this host. Check the spelling of this name, then ││
│ │ your "/etc/hosts" file, or your "/etc/resolv.conf" file and ││
│ │ DNS resolver configuration. The nslookup program may be ││
│ │ helpful in isolating this problem.

│     * Beginning Analysis Phase. ││
│ │ * Source: ││
│ │ housigmaux.sigma.lan:/SD_FILE/MirrorDisk_UX.tar │
│ │ * Target: housigmaux:/ │
│ │ * Target logfile: housigmaux:/var/adm/sw/swagent.log │
│ │ * Reading source for product information. ││
│ │ ERROR: RPC exception: "Invalid network address (dce / rpc)" 06/26/13 ││
│ │ 13:06:15 CDT ││
│ │ ERROR: Could not open remote depot/root "/SD_FILE/MirrorDisk_UX.tar" ││
│ │ due to an RPC or network I/O error.

 

 

I found out that PHCO_39205 can cause this problem: http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c02454496&jumpid=reg_R1002_USEN

 

But, i cant see that patch installed on my system. How can i remove it? Or how can i get passed this issue?

 

Thanks.

 

 

P.S> This thread has been moved from HP-UX > System Administration to Patches - HP Forum Moderator

3 REPLIES
Honored Contributor Honored Contributor

Re: hostname not found when installing MirrorDisk/UX

If you do:

 

# nslookup 192.168.100.40

 

What is returned?  Is the host name returned?

 

If not check your /etc/hosts file and make sure there is an entry for the server there.

 

If it is still failing you may need to check your DNS set up.  Make sure your appropriate DNS servers are defined in /etc/resolv.conf and make sure your /etc/nsswitch.conf file is set up appropriately as well.

 

 

Frequent Advisor

Re: hostname not found when installing MirrorDisk/UX

The patch is definitely not installed...

# swlist -l patch | grep 3920
PHCO_39202.CORE-JPN-E-MAN 1.0 OS-Core.CORE-JPN-E-MAN applied
PHCO_39204.CORE-JPN-E-MAN 1.0 OS-Core.CORE-JPN-E-MAN applied
PHCO_39206.CORE-JPN-E-MAN 1.0 OS-Core.CORE-JPN-E-MAN applied
PHCO_39202.CORE-JPN-S-MAN 1.0 OS-Core.CORE-JPN-S-MAN applied
PHCO_39204.CORE-JPN-S-MAN 1.0 OS-Core.CORE-JPN-S-MAN applied
PHCO_39206.CORE-JPN-S-MAN 1.0 OS-Core.CORE-JPN-S-MAN applied
# PHCO_39202 1.0 rtsched Japanese manpage patch
# PHCO_39202.CORE-JPN-E-MAN 1.0 OS-Core.CORE-JPN-E-MAN applied
# PHCO_39202.CORE-JPN-S-MAN 1.0 OS-Core.CORE-JPN-S-MAN applied
# PHCO_39204 1.0 cp(1) Japanese cumulative manpage patch
# PHCO_39204.CORE-JPN-E-MAN 1.0 OS-Core.CORE-JPN-E-MAN applied
# PHCO_39204.CORE-JPN-S-MAN 1.0 OS-Core.CORE-JPN-S-MAN applied
# PHCO_39206 1.0 ioinit(1M) Japanese cumulative manpage patch
# PHCO_39206.CORE-JPN-E-MAN 1.0 OS-Core.CORE-JPN-E-MAN applied
# PHCO_39206.CORE-JPN-S-MAN

Highlighted
Frequent Advisor

Re: hostname not found when installing MirrorDisk/UX

Yeah, the default install does DNS first and since it is a new server the A records have not been setup. Changed to "files dns" and it worked.

Thanks a lot.