Performance Center Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Citrix session closes while recording through loadrunner 9.5

Highlighted
Occasional Advisor

Citrix session closes while recording through loadrunner 9.5

Hi,

I am trying to record a Citrix based application using Loadrunner.The application is hosted on a citrix server and is accessible through an https based url.

I tried recording using HTTP+Citrix ICA protocol.  The Loadrunner version is 9.52 and the citrix ICA client version is 10.2 and Citrix Receiver version is 13.1 on my machine where loadrunner is installed.

The problem is that i can access the citrix based application manually however when i try to record it using loadrunner, as soon as i click on the application icon on citrix server, the internet explorer session closes and the application also doesn't open up.

 

Please suggest how to fix this issue.

2 REPLIES
HPE Expert

Re: Citrix session closes while recording through loadrunner 9.5

You should start checking your antivirus on your machine, have it disabled and see if it works, also verify DEP settings on your machine are set to Windows programs and services only.

 

Regards,

Mario M.

HP LR/PC Support

If you are customer you can try posting on our internal forums for more personalized support.

LoadRunner:
http://h30499.www3.hp.com/t5/LoadRunner-Support-Customer/bd-p/loadrunner-support-customer-forum

Performance Center:
http://h30499.www3.hp.com/t5/Performance-Center-Support/bd-p/performance-center-support-customer

How to:
http://www.youtube.com/watch?v=4ChlysWupWM

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Occasional Visitor

Re: Citrix session closes while recording through loadrunner 9.5

Hi Shwetha,

 

From the description of your problem it seems that your IE program (Citrix APP URL) crashes when you are trying to open it via VUGen... are you trying this on a win 7 machine with VUGen 9.5?

 

I guess the IE is getting closed due to DEP (Data Execution Prevention) settings being "turned on" in your system. If this is the case then please add VUGen and IE to the exception list.

 

See the attached screenshot for details.

 

Hope this helps, kindly mark this solution as solved if it really helps.

 

Regards,

Sunil Kumar